2

Bukkit or Spout?

  • 3,565
    Views, 2 today
  • 8 Comments
  • 0 Favorites
  • Flag / Report

Get Embed Code

Forum:
HTML:
Link:
avatar
nexxusnoir
Level 34 : Artisan Creeper Hugger
Every one knows that Bukkit does not like Spout and the Spout people don't much like Bukkit. Recently the two have reached an impasse and Spout announced that they would be leaving Bukkit and starting their own Server. This means, that rather sooner than later,(within the year if you listen to the grapevine) Spout plugins will no longer work on Bukkit, rendering most Spoutcraft based servers useless.
This is not to say that most of the servers will not just switch to the new spout server/client API, but this also means a new set of plugins with all things that come with new plugins (bugs) and a whole new set of commands and permissions.not to mention all being hosted on a new and untested/stable? server. My question is, what do you think, will the spout crowd stay loyal? or will Bukkit just push for its own spout like plugin and wipe the floor with spout all together? At the end of the day what would you choose The Bukkit or the Spout?
Tags:Minecraft, Spout, Bukkit, Plugins, spoutcraft, Review

More Blogs by nexxusnoirView All

Posted 2011-09-15 07:13:46
by nexxusnoir
Posted 2011-11-22 13:03:22
by nexxusnoir

Comments : 8

Join us to post comments.

1 - 8 of 8

nickolaiproblem
Level 1
New Crafter
June 30, 2014, 3:40 pm

to be honest  like spout but i if it not compatible with your version of bukkit forget about spout

Turabi333
Level 4
Apprentice Miner
October 25, 2013, 6:04 pm

I would just choose Bukkit I hate Spout

mohawkguy360
Level 1
New Explorer
March 12, 2013, 2:42 pm

I personally love using Spout. But.. My server started out as Bukkit and it would be hard to switch on people

gunblast
Level 50
Grandmaster Soldier
February 21, 2013, 3:30 pm

Recently spout has really shaped up, I'd prefer it to bukkit anyday

Irkensir
Level 1
New Miner
February 15, 2012, 8:01 am

spout[size=10pt] will have a different API ,but they will provide a compatibility plugin to make bukkit plugins run on a spout server [/size]quote: [size=15px][color=rgb(20,20,20)][bgcolor=rgb(252,252,255)]we will provide a [/bgcolor][/color][/size][size=15px][color=rgb(20,20,20)][bgcolor=rgb(252,252,255)]compatibility[/bgcolor][/color][/size][size=15px][color=rgb(20,20,20)][bgcolor=rgb(252,252,255)]plugin that can serve as an interface for any Bukkit plugin(s) that haven't been ported to Spout.[/bgcolor][/color][/size]
[size=15px][color=rgb(20,20,20)][bgcolor=rgb(252,252,255)]so bukkit pluggins WILL stil work on a spout server,butt spout pluggins not on a bukkit server[/bgcolor][/color][/size][size=15px][color=rgb(20,20,20)][bgcolor=rgb(252,252,255)]knowing this there is no reason to stick with bukkit[/bgcolor][/color][/size]
[size=15px][color=rgb(20,20,20)][bgcolor=rgb(252,252,255)]if bukkit does not support spout and spout supports bukkit plugins obv. i will run a spout server and not a bukkit one ,with spout i can have the cool bukkit plugins + spout gui new items ,new blocks etc..[/bgcolor][/color][/size]
[size=15px]and clients won't know what server I'm running anyway[/size]

[size=15px]another bonus is that clients won't have to wait to update to the new release of minecraft since you will still be able to play on the server even if your client is a version higher[/size]
[size=15px]this is not possible with bukkit[/size]

[size=15px]this last thing is probably the most important of all ,not having to wait on updates[/size]

nexxusnoir
Level 34
Artisan Creeper Hugger
February 15, 2012, 3:48 pm

valid points that i was not aware of, thanks for the info!

clitcomander
Level 1
New Explorer
January 25, 2012, 3:02 am

end of the day, I choose bukkit. Spout is not essential to what I do. I never got along with spout myself, corrupts worlds and what have you.

nexxusnoir
Level 34
Artisan Creeper Hugger
January 25, 2012, 9:00 am

totally agree spout is a quick way to corrupt a world and if you have no back ups, put you right back at square one!

1 - 8 of 8