Cross version server

Are you new to setting up a server and need a bit of pointing in the right direction? This is the place to be.

Post Permalink
by MinexPRO » 4/21/2017

Hello, I run a server using 1.11.2 since it is a Survival server and like to keep it updated with the newest version to keep players joining. But, recently I've seen Survival servers that run all the way from 1.8 to 1.11. My question is would it be best to stay at 1.11.2 or lower down to 1.8 and cover a range of versions?
User avatar
Level 1
New Network
Posts: 5
Joined: 10/17/15

Post Permalink
by Thatsmusic99 » 4/21/2017

If you've already updated to 1.11.2, it's not a good idea to lower back down to 1.8. Your server already uses 1.11.2 blocks and entities after all.
User avatar
Level 9
Apprentice Engineer
Posts: 87
Joined: 11/6/16
Location: Planet Earth
Says: HWAH!!!
Minecraft: Thatsmusic99
mc_server: myluciddreams.com

Post Permalink
by Nitwick » 4/21/2017

Downgrading a server is a bad idea. If the mechanical reasons above weren't relevant, I still wouldn't recommend it - people who refuse to update to new versions to join the server have the issues entirely on them, not on you. If you did stay on 1.8, you could have done viaversion. However, 1.8 is, in the computing world, approaching stone age time levels. There is only one valid, wide-encompassing reason I've seen to stay on 1.8, and that is the PVP mechanics. However, even that reason isn't actually valid - you can put a plugin on the server that removes the pvp cooldown if your community has such an issue with it.
"It is no coincidence that snowmen are always white, professor Cusack argues"
~Daily Mail
User avatar
Level 2
Apprentice Mage
Posts: 1751
Joined: 3/21/15


Return to Server Help