home Forumsplay_arrow Communities play_arrow Redstone

1

Command rarely not working.

1 emeralds4 replies66 views
created 06/25/2019 5:44 pm by MaximoAlex8300
last reply 06/27/2019 1:39 pm
I'm making a map (In Java) and obviusly i'm using command blocks. One of them is supposed to detect when a button is powered, but i have some trouble to make it work. The command goes like this:

execute if block 8 62 -3 #minecraft:wooden_buttons[facing=south,powered=true] run setblock 20 4 24 minecraft:redstone_block

The command block have his settings to Repeat and Always Active.

The version is 1.14.3

Even more rare is that when I type it in the Chat... It works. Help!
Posted by avatar
MaximoAlex8300
Level 1 : New Miner
0

comment Login or register to post a reply.

4 replies

2
06/26/2019 6:19 am
Level 7 : Apprentice Modder
HoboMaggot
I have tested this command (except I changed the cords) and the command is indeed working.
Is the command block within the server chunk distance (usually 10 chunks), or your chunk render distance.
It may fail to do anything if it's not nearby.
1
06/26/2019 6:31 pm
Level 1 : New Miner
MaximoAlex8300
If you watch the two Y values you can see that they are pretty far, but only the Y, the command is pretty close to the second X Y and Z values, It may be that they are too far away by the Y coordinates? The X and Z are pretty close so i'm questioning if is the Y affecting the command.
2
06/27/2019 4:27 amhistory
Level 7 : Apprentice Modder
HoboMaggot
It could, but check your render distance as well. And test it near the command block
2
06/27/2019 1:39 pm
Level 1 : New Miner
MaximoAlex8300
Ok, thanks, it worked now, I'm going to keep that in mind when I do another map. Thanks for the help!

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome