Forumskeyboard_arrow_right Help keyboard_arrow_right Java Edition

Create Forum Thread
2

Can't connect to friend's Game!

2 emeralds7 replies188 views
created 12/25/2019 7:53 pm by WandererReece history
last reply 01/17/2020 10:43 pm
My friend and I are playing survival Minecraft together over LAN (as in local area network). We are playing a world created in 1.14.4, and it has NOT been updated to 1.15 yet. We are using Fabric 0.4.1 build 25-1.14, LiteMatica 1.14.4-0.0.0, Minihud 1.14.4-0.19.0, and Optifabric 0.7.1 with Optifine 1.14.4 hduf5. The java version is 8 update 231.

We used to connect without any problems, but now I just can't join. I checked all the usual culprits, like firewalls, and nothing worked! We tried switching to vanilla 1.14.4, and still it didn't work. I can see his game, but I keep timing out for unknown reasons. Furthermore, he tried to join a game hosted by me, but he couldn't even see the game!

At the moment, the only thing I can think of is Win 10. I downgraded my laptop to Win 7 Pro x64 years ago, but I have recently re-upgraded the laptop to Win 10 Pro x64. So far, everything else works, including the wifi.

At the moment, I can only assume that Win 10 is somehow the problem. I hope someone here is tech-savy enough to have the solution or at least point me in the right direction.
Posted by avatar
WandererReece
Level 9 : Apprentice Miner
2

comment Login or register to post a reply.

7 replies

1
01/04/2020 9:35 am
Level 1 : New Explorer
Sup3rAJ
Have you tried directly connecting an Ethernet cable between your PC's if Possible? if you had been timing out then a direct connection could solve the issue but then again it might not, though it's a good solution to try at least.
1
12/26/2019 12:56 amhistory
Level 8 : Apprentice Network
RecoladaMC
What error are you getting when you attempt to connect? Also posting a log would help. Any time you boot up minecraft it produces logs, either single player or multiplayer. latest.log should be fine. Simply connect to the server and then post the results of latest.log
1
12/25/2019 9:33 pm
Level 3 : Apprentice Miner
icephantom
Network issues like this can be difficult to track down - solutions that work for some, won't work for others, so it often comes down to trial and error.
If you've recently updated to Win 10, try going to PC settings, Network and Internet, Change adaptor properties. Open up the 'ethernet' connection icon by right-clicking on it and choosing 'properties'. Take out the tick for Qos and internet connection version 6, unless you are using version 6 - unlikely since most routers are still set for ver. 4. Also look in the list to see if there are any protocols related to a virus checker you might be using and un-tick those as well. Click ok and give things a try .......... It sounds as though its either the in-built windows firewall, or you've installed third party software that has a firewall, or you haven't allowed the
C:\Program Files (x86)\Common Files\Oracle\Java\javapath_target_2733598062\javaw.exe file through your firewall (this path may be slightly different on your system depending on hava version installed).
1
12/31/2019 8:01 pm
Level 9 : Apprentice Miner
WandererReece
Unfortunately, I can confirm that firewalls are not the problem. We have them disabled for the LAN. We got tired of always having to configure them for games, lol.

I tried disabling the stuff you mentioned, and it did not work, but I'm not surprised. That stuff is usually handled by routers, not clients.

I know everyone usually need to have the exact, same mods installed, so I checked for updates to our mods and downloaded all of them. Then I installed them on both our PCs. That didn't work either.

I think I forgot to mention I double checked the router settings. They are unchanged from when we could join each other's games.

Also, I just copied the exact error message, "io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection timed out: no further information:" I don't know why I didn't think to post it earlier.

To Summarize:
Not firewall related
Not QoS or IPv6 related
Not mod related
Not wire related

What does this leave? One major headache, lol.
2
01/02/2020 11:02 pm
Level 3 : Apprentice Miner
icephantom
Not sure if this link will assist, but there are a couple of suggestions in it about your problem :

https://appuals.com/fix-io-netty-channel-abstractchannelannotatedconnectexception-connection-refused-no-further-information-error-on-minecraft/
1
01/17/2020 10:43 pm
Level 9 : Apprentice Miner
WandererReece
I just gave that article a quick read. That's just basic troubleshooting stuff, and I severely doubt a non-static address would cause a problem.
1
01/17/2020 10:39 pm
Level 9 : Apprentice Miner
WandererReece
Thanks for the link. However, maybe 2 weeks after my update, no one could go online. EVERYTHING checked out. I eventually reset the whole router, and the problem was fixed. Next day, there was no internet again. The wierd part is the router will accurately detect an active internet connection, even when no one can go online.

We now believe that the router is dying. Believe it or not, it's over a decade old. It will be missed.

The funny part is I'm having tons of trouble finding a new router with a certain wifi feature that was in the old one. I may have to settle for something close to it and just find a way to make it work. I thought I would be getting an upgrade after all these years! LOL!
Planet Minecraft Logo

Website

© 2010 - 2020
www.planetminecraft.com

Welcome