forum Forumskeyboard_arrow_right Help keyboard_arrow_right computerJava Edition

Create Forum Thread
1

Functions not showing up at all

1 emeralds4 replies2,368 views
Nevermind3476 started 05/05/2018 11:28 pm
and replied 05/06/2018 11:43 am
I'm trying to run a function from my datapack but none of them will show up and it says even the default minecraft tags aren't recognized. I'm in 18w16a
Posted by avatar
Nevermind3476
Level 21 : Expert Modder
11

comment Login or register to post a reply.

4 replies

2
05/05/2018 11:46 pmhistory
Level 18 : Journeyman Engineer
SUPERIONtheKnight
I need more info.

Do you have a "pack.mcmeta"?
What's your folder structure?
Are you sure that your functions are .mcfunction files?
Are your tags .json files?
Do you have any invalid commands inside of your function files?
Do you have a / at the beginning of a command?

See here for setting up a datapack.

These are the first few things that come to mind. Let me know when you have the answers and I will do my best to help.
~SUPERIONtheKnight
1
05/06/2018 12:03 am
Level 21 : Expert Modder
Nevermind3476
I have a pack.mcmeta that's working fine, my functions are in data/cars/functions, and the only tag I have is data/minecraft/tags/functions/tick, all my files have the right endings, and my commands seem correct.
1
05/06/2018 12:30 amhistory
Level 18 : Journeyman Engineer
SUPERIONtheKnight
Have you reloaded the world with /reload? Datapacks have to be reloaded before changes will take effect.

Do you have any errors popping up in your logs? Easiest way to check is to go to settings in the vanilla launcher and make sure the following is turned on: "Open output log when game starts"

EDIT: Is the problem simply that the tick tag isn't running the function? Try running the function manually with a /function command and tell me if that works.

If reloading doesn't work, and there aren't any errors, can I see a sample of your datapack? It would make it easier for me to help you figure this out.
~SUPERIONtheKnight
2
05/06/2018 11:43 am
Level 21 : Expert Modder
Nevermind3476
turns out the command wasn't working, it's fixed now thanks for the help
Planet Minecraft Logo

Website

© 2010 - 2020
www.planetminecraft.com

Welcome