Forumskeyboard_arrow_right Help keyboard_arrow_right Java Edition

Create Forum Thread
1

Thaumcraft Crashes Game on Startup

1 emeralds1 reply65 views
created 09/15/2019 6:53 pm by Breakerbomb
last reply 09/15/2019 8:01 pm
Bro, every time I load Thaumcraft I get this rachet ass crash, I got a potato computer but that shouldn't be an issue since I used Thaumcraft before back in the 1.7.10 days. When I start Thaumcraft by itself, it complains, talkin' bout sum "I need Baubles to start". So I download Baubles and the games crashes on some lightskin stuff. Here's the output.

[18:51:10] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[18:51:10] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[18:51:10] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
[18:51:10] [main/INFO] [FML]: Forge Mod Loader version 14.23.5.2847 for Minecraft 1.12.2 loading
[18:51:10] [main/INFO] [FML]: Java is Java HotSpot(TM) Client VM, version 1.8.0_131, running on Windows 10:x86:10.0, installed at C:\Program Files (x86)\Java\jre1.8.0_131
[18:51:11] [main/WARN] [FML]: The coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin) is not signed!
[18:51:11] [main/WARN] [FML]: The coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin) is not signed!
[18:51:11] [main/INFO] [FML]: Searching C:\Users\Hope.livingspace\AppData\Roaming\.minecraft\mods for mods
[18:51:11] [main/INFO] [FML]: Searching C:\Users\Hope.livingspace\AppData\Roaming\.minecraft\mods\1.12.2 for mods
[18:51:11] [main/WARN] [FML]: Found FMLCorePluginContainsFMLMod marker in Minema-Mod-Unofficial-1.12.2.jar. This is not recommended, @Mods should be in a separate jar from the coremod.
[18:51:11] [main/WARN] [FML]: The coremod ShaderHookLoader (info.ata4.minecraft.minema.shaderHook_coremod.ShaderHookLoader) is not signed!
[18:51:11] [main/WARN] [FML]: Found FMLCorePluginContainsFMLMod marker in SmartMoving-1.8.9-16.3.jar. This is not recommended, @Mods should be in a separate jar from the coremod.
[18:51:11] [main/ERROR] [FML]: The coremod net.smart.core.SmartCorePlugin is requesting minecraft version 1.8.9 and minecraft is 1.12.2. It will be ignored.
[18:51:11] [main/WARN] [FML]: Found FMLCorePluginContainsFMLMod marker in techguns-1.12.2-2.0.2.0_pre3.1.jar. This is not recommended, @Mods should be in a separate jar from the coremod.
[18:51:11] [main/WARN] [FML]: The coremod Techguns Core (techguns.core.TechgunsFMLPlugin) is not signed!
[18:51:11] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[18:51:11] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[18:51:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[18:51:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[18:51:11] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[18:51:17] [main/INFO] [FML]: Found valid fingerprint for Minecraft. Certificate fingerprint cd99959656f753dc28d863b46769f7f8fbaefcfc
[18:51:17] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[18:51:17] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[18:51:17] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[18:51:17] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[18:51:18] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[18:51:19] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
[18:51:19] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
[18:51:19] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[18:51:23] [Client thread/INFO] [minecraft/Minecraft]: Setting user: Breakerbomb
[18:51:32] [Client thread/WARN] [minecraft/GameSettings]: Skipping bad option: lastServer:
[18:51:32] [Client thread/INFO] [minecraft/Minecraft]: LWJGL Version: 2.9.4
[18:51:34] [Client thread/INFO] [FML]: MinecraftForge v14.23.5.2847 Initialized
[18:51:34] [Client thread/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
[18:51:34] [Client thread/INFO] [FML]: Invalid recipe found with multiple oredict ingredients in the same ingredient...
[18:51:34] [Client thread/INFO] [FML]: Replaced 1227 ore ingredients
[18:51:35] [Client thread/INFO] [FML]: Searching C:\Users\Hope.livingspace\AppData\Roaming\.minecraft\mods for mods
[18:51:35] [Client thread/INFO] [FML]: Searching C:\Users\Hope.livingspace\AppData\Roaming\.minecraft\mods\1.12.2 for mods
[18:51:38] [Client thread/ERROR] [FML]: Unable to construct net.minecraftforge.fml.common.Mod container
java.lang.reflect.InvocationTargetException: null
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_131]
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_131]
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_131]
at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_131]
at net.minecraftforge.fml.common.ModContainerFactory.build(ModContainerFactory.java:73) [ModContainerFactory.class:?]
at net.minecraftforge.fml.common.discovery.JarDiscoverer.findClassesASM(JarDiscoverer.java:114) [JarDiscoverer.class:?]
at net.minecraftforge.fml.common.discovery.JarDiscoverer.discover(JarDiscoverer.java:77) [JarDiscoverer.class:?]
at net.minecraftforge.fml.common.discovery.ContainerType.findMods(ContainerType.java:47) [ContainerType.class:?]
at net.minecraftforge.fml.common.discovery.ModCandidate.explore(ModCandidate.java:74) [ModCandidate.class:?]
at net.minecraftforge.fml.common.discovery.ModDiscoverer.identifyMods(ModDiscoverer.java:93) [ModDiscoverer.class:?]
at net.minecraftforge.fml.common.Loader.identifyMods(Loader.java:427) [Loader.class:?]
at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:568) [Loader.class:?]
at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:232) [FMLClientHandler.class:?]
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467) [bib.class:?]
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378) [bib.class:?]
at net.minecraft.client.main.Main.main(SourceFile:123) [Main.class:?]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_131]
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_131]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_131]
at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_131]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
Caused by: java.lang.IllegalArgumentException: The modId SmartMoving must be all lowercase.
at net.minecraftforge.fml.common.FMLModContainer.sanityCheckModId(FMLModContainer.java:157) ~[FMLModContainer.class:?]
at net.minecraftforge.fml.common.FMLModContainer.<init>(FMLModContainer.java:128) ~[FMLModContainer.class:?]
... 22 more
[18:51:39] [Client thread/INFO] [FML]: Forge Mod Loader has identified 13 mods to load
[18:51:39] [Client thread/INFO] [FML]: FML has found a non-mod file Mods.zip in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.
[18:51:39] [Client thread/INFO] [FML]: FML has found a non-mod file orespawn-1.7.10-20.3.zip in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.
[18:51:39] [Client thread/INFO] [FML]: FML has found a non-mod file SmartMoving-1.8.9-16.3.jar in your mods directory. It will now be injected into your classpath. This could severe stability issues, it should be removed if possible.
[18:51:40] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, techguns_core, baubles, bauercam, guideapi, minema, cfm, techguns, thaumcraft, worldedit] at CLIENT
[18:51:40] [Client thread/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, techguns_core, baubles, bauercam, guideapi, minema, cfm, techguns, thaumcraft, worldedit] at SERVER
[18:51:43] [Client thread/INFO] [STDOUT]: [techguns.core.TechgunsASMTransformer:patchItemRenderer_updateEquippedItem:528]: Successfully patched ItemRenderer.updateEquippedItem with ASM
[18:51:43] [Client thread/INFO] [STDOUT]: [techguns.core.TechgunsASMTransformer:patchRenderItem_patchMethodRenderModel:480]: Successfully patched 2 arg RenderItem.RenderModel with ASM
[18:51:43] [Client thread/INFO] [STDOUT]: [techguns.core.TechgunsASMTransformer:patchRenderItem_patchMethodRenderItem:299]: Successfully patched 4 arg RenderItem.RenderItem with ASM
[18:51:43] [Client thread/INFO] [STDOUT]: [techguns.core.TechgunsASMTransformer:patchRenderItem_patchMethodRenderItemGUI:423]: Successfully patched RenderItem.renderItemModelIntoGUI with ASM
[18:51:43] [Client thread/INFO] [STDOUT]: [techguns.core.TechgunsASMTransformer:patchRenderEntityItem:169]: Successfully patched RenderEntityItem with ASM
[18:51:43] [Client thread/INFO] [STDOUT]: [techguns.core.TechgunsASMTransformer:patchRenderEntityItem:169]: Successfully patched RenderEntityItem with ASM
[18:51:45] [Client thread/INFO] [minecraft/SimpleReloadableResourceManager]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Baubles, FMLFileResourcePack:BauerCam, FMLFileResourcePack:Guide-API, FMLFileResourcePack:Minema, FMLFileResourcePack:MrCrayfish's Furniture Mod, FMLFileResourcePack:Techguns, FMLFileResourcePack:Thaumcraft, FMLFileResourcePack:WorldEdit
[18:51:45] [Client thread/INFO] [FML]: Processing ObjectHolder annotations
[18:51:45] [Client thread/INFO] [FML]: Found 1189 ObjectHolder annotations
[18:51:45] [Client thread/INFO] [FML]: Identifying ItemStackHolder annotations
[18:51:45] [Client thread/INFO] [FML]: Found 0 ItemStackHolder annotations
[18:51:45] [Client thread/INFO] [FML]: Configured a dormant chunk cache size of 0
[18:51:45] [Forge Version Check/INFO] [forge.VersionCheck]: [techguns] Starting version check at raw.githubusercontent.com/pWn3d1337/Techguns2/master/update.json
[18:51:47] [Forge Version Check/INFO] [forge.VersionCheck]: [techguns] Found status: AHEAD Target: null
[18:51:47] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Starting version check at files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json
[18:51:47] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Found status: AHEAD Target: null
[18:51:52] [Client thread/INFO] [FML]: OBJLoader: Domain techguns has been added.
[18:51:53] [Client thread/INFO] [FML]: OBJLoader: Domain thaumcraft has been added.
An unrecoverable stack overflow has occurred.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_STACK_OVERFLOW (0xc00000fd) at pc=0x5ba612e7, pid=9496, tid=0x000023c0
#
# JRE version: Java(TM) SE Runtime Environment (8.0_131-b11) (build 1.8.0_131-b11)
# Java VM: Java HotSpot(TM) Client VM (25.131-b11 mixed mode windows-x86 )
# Problematic frame:
# C [ig7icd32.dll+0x3f12e7]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# C:\Users\Hope.livingspace\AppData\Roaming\.minecraft\hs_err_pid9496.log
#
# If you would like to submit a bug report, please visit:
# bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Posted by avatar
Breakerbomb
Level 1 : New Explorer
0

comment Login or register to post a reply.

1 reply

1
09/15/2019 8:01 pm
Level 16 : Journeyman Modder
guestds
it seems like you have smart moving installed for 1.8.9 so try removing them (move them to a separate folder) as youre using 1.12

if it still doesnt work post a crash report (youve posted the launcher log) found in: %appdata%/.minecraft/crash-reports
sort that folder by date modified and paste all of the latest files text as a reply and in a spoiler

Planet Minecraft

Browse

Site

© 2010 - 2019
www.planetminecraft.com

Welcome