forum Forumsplay_arrow Minecraft fiber_manual_record Help

1

How To Get Modded World To Work ON LAN (1.12.2)

1 emerald11 replies117 views
created 03/18/2019 9:04 pm by Trismon55555
last reply 03/20/2019 4:39 am
Hello,
Currently me and my siblings are having issues with LAN worlds not working.
We wanted to try survival with some mods, and I made sure we all had the EXACT same mods, optifine, and forge version.

But to no avail, one cant seem to even get the LAN connection tab, while the other can, but wont connect.

So I as you kind members of the minecraft community, HELP PLZ.

EDIT:
After further experimentation, the issue has been deduced to FORGE
the forge version I am using is forge-1.12.2-14.23.5.2795

also, some people are confused what i meant by LAN connection tab. Its the little tab that shows up in the multiplayer list at the bottom when someone opens a world to LAN in the area.

REEDIT: alright now, the issue isnt Forge, now its just LAN 1.12.2 just wont work, vanilla or modded.
Posted by avatar
Trismon55555
Level 1 : New Miner
0

11 replies

03/19/2019 10:10 am
Level 20 : Expert Engineer
DiggerMcGee
Add a new server to your client's multiplayer tab list with the IP of the machine hosting the session.
03/19/2019 9:53 am
Level 1 : New Miner
Trismon55555
Ok, nvm we figured it out.
03/19/2019 5:27 am
Level 8 : Apprentice Engineer
Geeri
Remove all client side mods. You can get those if you look at the crash log. At the start of the crashlog it will say something like "Loaded = L" and "Crashed = C " just for example. Skim through the list and search for mods that crash.
03/19/2019 6:58 am
Level 1 : New Miner
Trismon55555
See, the thing is mods don't seem to be the issue, because I tested the forge version without any mods, yet LAN still doesn't seem to work.
03/20/2019 4:39 am
Level 8 : Apprentice Engineer
Geeri
Try to do it then provide us with the latest.log of the person who can't seem to join. You can find that by going in to the folder of the modded minecraft instance by default that'd be in appdata which you'd reach by hitting the windowskey+r and typeing %appdata%. But there's a chance that your instance folder is some where else. If you can't find it just go into Options -> Rescource Packs in game and click open folder. You can navigate back by clicking the little tags on top if you're on windows. Go to logs and find the latest.log file.
03/19/2019 2:55 am
Level 39 : Artisan Engineer
ShelLuser
First try to rule out what's causing the problems.

So: start by disabling all the mods (just rename the directory for example or dump them into a new sub folder) and then start the client again. Check if you can connect to each other that way. Because I can't help wonder if this isn't caused by some mod going haywire.

btw: LAN connection tab? What's that supposed to be anyway? Because the only options you have are single player and multiplayer. The option "Open to LAN" isn't a tab but a button, which should always be there no matter what. So if it isn't then I'm guessing some mod is acting up.
03/19/2019 4:21 am
Level 1 : New Miner
Trismon55555
I have been doing some tests, and what I have deduced was that forge is being the issue. I am currently using forge-1.12.2-14.23.5.2795 because one of the mods I'm using required it. I did the method you have described, yet the issue still remains in the forge version.

p.s. I should be more specific, when I meant LAN connection tab; i meant that little multiplayer tab at the bottom that shows up when someone in the same internet router starts a LAN world.
03/19/2019 12:12 am
Level 1 : New Explorer
X_Eaglefrost_X
Okay, my first suggestion is, have you all of you tried hosting a world? It may be something about the specific computer that isn't working.

If that doesn't work, try restarting the computer(s) and trying again, that can sometimes be an issue.

Once you've tried both of these if it still doesn't work let me know and I can help you some more.
03/19/2019 4:33 am
Level 1 : New Miner
Trismon55555
The issue isn't the host computer, because the multiplayer tab (LAN connection tab) shows up one the other computers, but when my siblings click to join, the connection just times out.

The problem doesn't appear when we do this in vanilla minecraft, and the mods dont seem to be the issue either (due to my brother hosting while one of the computers had a tree chopping and chest organization mod and it still ran).
The issue that I have deduced when trying a LAN server with NO mods on 2 of our 3 computers is Forge.

For the record, we are on forge-1.12.2-14.23.5.2795 if that helps.
I appreciate you helping any way you can dude.
03/18/2019 9:40 pm
Level 4 : Apprentice Warrior
FuryDesert
If the LAN tab isn't even there, it means you're playing on a version from before it was added.

If you're having issues with LAN worlds not showing up even though you're on the same network try disabling your firewall.

It's a little complicated but if this still doesn't work, you can watch a tutorial on how to add inbound connection exceptions within your homegroup
03/18/2019 9:56 pm
Level 1 : New Miner
Trismon55555
1. This is version 1.12.2 of minecraft. so all of the computers used do have the LAN world option

2. On my sisters laptop it isnt showing, so that could be the issue there. But my brothers is showing up, but it keeps saying connection timed out when he tries to get on.

3. I have been doing some tampering around to deduce the issue, this research pointed to forge being the problem, i have forge-1.12.2-14.23.5.2795 as its required for a mod, but aparrently it doesn't allow LAN to work.

If you have a video in mind that may be of assistance, send me the link.

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome