forum Forumsplay_arrow Minecraft fiber_manual_record Help

1

NEED HELP WITH PERMISSION PLEASEEE

1 emerald8 replies53 views
created 10/15/2018 10:39 am by laxanovaaa
last reply 10/15/2018 11:35 am
really need help with giving non op players s certain commands like set home please help
Posted by avatar
laxanovaaa
Level 10 : Journeyman Miner
0

8 replies

1
10/15/2018 11:10 am
Level 34 Artisan Engineer
ShelLuser
avatar
The only way to do this is to use a permission plugin such as PermissionsEx or LuckPerms. After you installed it you then need to check whatever plugin is providing those commands, check what permission node they use and then give the user(s) access to those nodes.
1
10/15/2018 10:59 am
Level 22 Expert Princess
ieryana
avatar
What permissions plugin are you using?

What groups do you have?




A little more info would go a long way :P
1
10/15/2018 11:14 am
Level 10 Journeyman Miner
laxanovaaa
avatar
Im using permissionsex
and im useing the default group ( im guessing thats the new players) ill copy the default group part. this is from the group manager folder
groups:
Default:
default: true
permissions:
- -bukkit.command.kill
- essentials.sethome
- essentials.home
inheritance:
- g:groupmanager_default
- g:bukkit_default
- g:essentials_default
- g:towny_default
info:
prefix: '&e'
build: false
suffix: ''
1
10/15/2018 11:17 am
Level 22 Expert Princess
ieryana
avatar
You should really look at using luckperms - PEX is pretty defunct now.

but anyways.




groups:
  Member:
  options:
    default: true
    prefix: '&6[&8M&6]&f'
    weight: '1000'
  permissions:
  - blah.blah
  - blah.blah

Try this set up?


Then you need to go and make sure what exactly the permission is that you want to grant them.

I don't understand why you have an inheritance in there?
1
10/15/2018 11:35 am
Level 10 Journeyman Miner
laxanovaaa
avatar
im getting luckyperms
i need essentials to right
1
10/15/2018 11:34 am
Level 10 Journeyman Miner
laxanovaaa
avatar
imma delete everything and reinstall plugins and do everything over again
1
10/15/2018 11:26 am
Level 10 Journeyman Miner
laxanovaaa
avatar
groups:
  default:
  options:
    default: true
    prefix: '&6[&8M&6]&f'
    weight: '1000'
  permissions:
  - essentials.*
  
still nothing
1
10/15/2018 11:32 am
Level 10 Journeyman Miner
laxanovaaa
avatar
ok imma tell you step by step what i do and u say if its right
first i go to groups.yml and on the default group i add the exact command but still it says you dont have permission to use this to the players
and default should be any player that joins so i dont know why they cant use the commands makes no sense what so ever

Search

Browse

Site

© 2010 - 2018
planetminecraft.com

Welcome