Forumskeyboard_arrow_right Minecraft - Java Edition keyboard_arrow_right Modding

Create Forum Thread
1

Mod loading crash

1 emeralds7 replies108 views
created 07/20/2019 5:55 am by TGamesCZ
last reply 07/22/2019 3:09 pm
I am making a modpack, but it crashes while loading.

---- Minecraft Crash Report ----
// You should try our sister game, Minceraft!

Time: 7/20/19 11:32 AM
Description: There was a severe problem during mod loading that has caused the game to fail

cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: cpw/mods/fml/common/network/IConnectionHandler
at cpw.mods.fml.common.LoadController.transition(LoadController.java:163)
at cpw.mods.fml.common.Loader.loadMods(Loader.java:544)
at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:208)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:480)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
at net.minecraft.client.main.Main.main(SourceFile:148)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
Caused by: java.lang.NoClassDefFoundError: cpw/mods/fml/common/network/IConnectionHandler
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:440)
at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
at com.google.common.eventbus.EventBus.post(EventBus.java:275)
at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:212)
at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:190)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
at com.google.common.eventbus.EventBus.post(EventBus.java:275)
at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:119)
at cpw.mods.fml.common.Loader.loadMods(Loader.java:513)
... 10 more
Caused by: java.lang.ClassNotFoundException: cpw.mods.fml.common.network.IConnectionHandler
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 34 more
Caused by: java.lang.ArrayIndexOutOfBoundsException


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
Minecraft Version: 1.7.10
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_51, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 339134168 bytes (323 MB) / 1238892544 bytes (1181 MB) up to 5592580096 bytes (5333 MB)
JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx6000m -Xms256m -XX:PermSize=256m
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 10.13.4.1566 Optifine OptiFine_1.7.10_HD_U_E7 75 mods loaded, 75 mods active
States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
UC mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
UC FML{7.10.99.99} [Forge Mod Loader] (forge-1.7.10-10.13.4.1566-1.7.10.jar)
UC Forge{10.13.4.1566} [Minecraft Forge] (forge-1.7.10-10.13.4.1566-1.7.10.jar)
UC appliedenergistics2-core{rv2-stable-10} [AppliedEnergistics2 Core] (minecraft.jar)
UC CodeChickenCore{1.0.7.47} [CodeChicken Core] (minecraft.jar)
UC Micdoodlecore{} [Micdoodle8 Core] (minecraft.jar)
UC NotEnoughItems{1.0.5.120} [Not Enough Items] (NotEnoughItems-1.7.10-1.0.5.120-universal.jar)
UC <CoFH ASM>{000} [CoFH ASM] (minecraft.jar)
UC mod_ThreadedLighting{1.7.10-1.0} [Threaded Lighting] (minecraft.jar)
UC debug{1.0} [debug] (denseores-1.6.2.jar)
UC gilded-games-util{1.7.10-1.2} [Gilded Games Utility] (gilded-games-util-1.7.10-1.9.jar)
UC CoFHCore{1.7.10R3.1.4} [CoFH Core] (CoFHCore-[1.7.10]3.1.4-329.jar)
UC BuildCraft|Core{7.1.23} [BuildCraft] (buildcraft-7.1.23.jar)
UC BuildCraft|Transport{7.1.23} [BC Transport] (buildcraft-7.1.23.jar)
UC BuildCraft|Silicon{7.1.23} [BC Silicon] (buildcraft-7.1.23.jar)
UC Waila{1.5.10} [Waila] (Waila-1.5.10_1.7.10.jar)
UC WailaAddonBC{1.0.5.1} [WailaAddonBC] ([1.7.10]WailaAddonBC-1.0.5.1.jar)
UC Baubles{1.0.1.10} [Baubles] (Baubles-1.7.10-1.0.1.10.jar)
UC adventurebackpack{1.7.10-0.8b} [Adventure Backpack] (adventurebackpack-1.7.10-0.8c.jar)
UC aether{1.7.10-1.6} [Aether II] (aether-1.7.10-1.6.jar)
UC appliedenergistics2{rv2-stable-10} [Applied Energistics 2] (appliedenergistics2-rv2-stable-10.jar)
UC D3Core{1.1.2.41} [D3Core] (D3Core-1.7.10-1.1.2.41.jar)
UC AutoCrafter2000{1.1.0.33} [AutoCrafter2000] (AutoCrafter2000-1.7.10-1.1.0.33.jar)
UC BiblioCraft{1.11.7} [BiblioCraft] (BiblioCraft[v1.11.7][MC1.7.10].jar)
UC BiomesOPlenty{2.1.0} [Biomes O' Plenty] (BiomesOPlenty-1.7.10-2.1.0.1889-universal.jar)
UC BuildCraft|Factory{7.1.23} [BC Factory] (buildcraft-7.1.23.jar)
UC BuildCraft|Robotics{7.1.23} [BC Robotics] (buildcraft-7.1.23.jar)
UC BuildCraft|Energy{7.1.23} [BC Energy] (buildcraft-7.1.23.jar)
UC BuildCraft|Builders{7.1.23} [BC Builders] (buildcraft-7.1.23.jar)
UC ThermalFoundation{1.7.10R1.2.6} [Thermal Foundation] (ThermalFoundation-[1.7.10]1.2.6-118.jar)
UC ThermalExpansion{1.7.10R4.1.5} [Thermal Expansion] (ThermalExpansion-[1.7.10]4.1.5-248.jar)
UC BuildCraft|Compat{7.1.7} [BuildCraft Compat] (buildcraft-compat-7.1.7.jar)
UC eureka{3.0.2} [Eureka] (Eureka-1.7.10-3.0.2.jar)
UC bcadditions{2.2.5} [BuildCraft Additions] (BuildcraftAdditions-1.7.10-2.2.5.jar)
UE Thaumcraft{3.0.5h1} [Thaumcraft] (Thaumcraft3.0.5h.zip)
UC Railcraft{9.12.2.0} [Railcraft] (Railcraft_1.7.10-9.12.2.0.jar)
UC TwilightForest{2.3.7} [The Twilight Forest] (twilightforest-1.7.10-2.3.7.jar)
UC chisel{2.9.5.11} [Chisel] (Chisel-2.9.5.11.jar)
UC CarpentersBlocks{3.3.8.2} [Carpenter's Blocks] (Carpenter's Blocks v3.3.8.2 - MC 1.7.10.jar)
UC ComputerCraft{1.75} [ComputerCraft] (ComputerCraft1.75.jar)
UC MineTweaker3{3.0.13} [MineTweaker 3] (CraftTweaker-1.7.10-3.0.13.jar)
UC evilcraft{0.9.13} [EvilCraft] (EvilCraft-1.7.10-0.9.13.jar)
UC ExtraUtilities{1.2.12} [Extra Utilities] (extrautilities-1.2.12.jar)
UC Mantle{1.7.10-0.3.2.jenkins191} [Mantle] (Mantle-1.7.10-0.3.2b.jar)
UC TConstruct{1.7.10-1.8.8.build988} [Tinkers' Construct] (TConstruct-1.7.10-1.8.8.jar)
UC GalacticraftCore{3.0.12} [Galacticraft Core] (GalacticraftCore-1.7-3.0.12.504.jar)
UC GalacticraftMars{3.0.12} [Galacticraft Planets] (Galacticraft-Planets-1.7-3.0.12.504.jar)
UC iChunUtil{4.2.3} [iChunUtil] (iChunUtil-4.2.3.jar)
UC Hats{4.0.1} [Hats] (Hats-4.0.1.jar)
UC instantblocks{1.5.4} [Instant Blocks] (InstantBlocks_v1.5.4.jar)
UC inventorytweaks{1.59-dev-152-cf6e263} [Inventory Tweaks] (InventoryTweaks-1.59-dev-152.jar)
UC journeymap{5.1.4p2} [JourneyMap] (journeymap-1.7.10-5.1.4p2-unlimited.jar)
UC llibrary{1.5.1} [LLibrary] (llibrary-1.5.1-1.7.10.jar)
UC jurassicraft{1.5.0} [JurassiCraft] (JurassiCraft-1.4.0.jar)
UC RadixCore{2.1.3} [RadixCore] (RadixCore-1.7.10-2.1.3-universal.jar)
UC MCA{1.7.10-5.2.2} [Minecraft Comes Alive] (MCA-1.7.10-5.2.2-universal.jar)
UC Morph{0.9.3} [Morph] (Morph-Beta-0.9.3.jar)
UC NEIAddons{1.12.14.40} [NEI Addons] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC NEIAddons|Developer{1.12.14.40} [NEI Addons: Developer Tools] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC NEIAddons|AppEng{1.12.14.40} [NEI Addons: Applied Energistics 2] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC NEIAddons|Botany{1.12.14.40} [NEI Addons: Botany] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC NEIAddons|Forestry{1.12.14.40} [NEI Addons: Forestry] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC NEIAddons|CraftingTables{1.12.14.40} [NEI Addons: Crafting Tables] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC NEIAddons|ExNihilo{1.12.14.40} [NEI Addons: Ex Nihilo] (neiaddons-1.12.14.40-mc1.7.10.jar)
UC neiintegration{1.1.2} [NEI Integration] (NEIIntegration-MC1.7.10-1.1.2.jar)
UC oreexcavation{1.1.134} [OreExcavation] (OreExcavation-1.1.134.jar)
UC placeableitems{2.0.1} [Placeable Items Mod] (placeableitems-2.0.1.jar)
UC PowerConverters3{1.7.10-2.11} [Power Converters 3] (PowerConverters-1.7.10-2.11.jar)
UC ProjectE{1.7.10-PE1.10.1} [ProjectE] (ProjectE-1.7.10-PE1.10.1.jar)
UE tcinventoryscan{1.0.11} [TC Inventory Scanning] (tcinventoryscan-mc1.7.10-1.0.11.jar)
UE ThaumicTinkerer{1.0.8} [Thaumic Tinkerer] (Thaumic Tinkerer [1.0.8].zip)
UC ThermalDynamics{1.7.10R1.2.1} [Thermal Dynamics] (ThermalDynamics-[1.7.10]1.2.1-172.jar)
UC aobd{2.9.2} [Another One Bites The Dust] (AOBD-2.9.2.jar)
UC denseores{1.0} [Dense Ores] (denseores-1.6.2.jar)
UC UniDict{1.7.10-2.9.2} [UniDict] (UniDict-1.7.10-2.9.2.jar)
GL info: ' Vendor: 'Intel' Version: '4.5.0 - Build 23.20.16.4849' Renderer: 'Intel(R) UHD Graphics 620'
CoFHCore: -[1.7.10]3.1.4-329
AE2 Version: stable rv2-stable-10 for Forge 10.13.2.1291
ThermalFoundation: -[1.7.10]1.2.6-118
ThermalExpansion: -[1.7.10]4.1.5-248
Mantle Environment: DO NOT REPORT THIS CRASH! Unsupported mods in environment: optifine
TConstruct Environment: Environment healthy.
ThermalDynamics: -[1.7.10]1.2.1-172
OptiFine Version: OptiFine_1.7.10_HD_U_E7
Render Distance Chunks: 9
Mipmaps: 4
Anisotropic Filtering: 1
Antialiasing: 0
Multitexture: false
Shaders: null
OpenGlVersion: 4.5.0 - Build 23.20.16.4849
OpenGlRenderer: Intel(R) UHD Graphics 620
OpenGlVendor: Intel
CpuCount: 8
Posted by avatar
TGamesCZ
Level 1 : New Network
0

comment Login or register to post a reply.

7 replies

2
07/21/2019 3:12 pm
Level 56 : Grandmaster Modder
Geforce
The version of Thaumcraft that you are using was made for Minecraft 1.5.2. Delete your version and replace it with this one. If the game still crashes after changing the file, post the new crash report using paste.ubuntu.com.
1
07/22/2019 3:00 pmhistory
Level 1 : New Network
TGamesCZ
2
07/22/2019 3:09 pm
Level 56 : Grandmaster Modder
Geforce
The version of Thaumic Tinkerer that you have installed was also made for 1.5.2. Delete it and replace it with a 1.7.10 port.
1
07/20/2019 1:23 pm
Level 60 : High Grandmaster Artist
oakar258
Try re-install forge
1
07/21/2019 5:36 am
Level 1 : New Network
TGamesCZ
I tried, but it still doesn't work.
1
07/21/2019 2:33 pm
Level 60 : High Grandmaster Artist
oakar258
Same crash?
1
07/22/2019 2:34 pm
Level 1 : New Network
TGamesCZ
yes

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome