forum Forumsplay_arrow Minecraft fiber_manual_record Mods

1

How to fix .class mod incompatibilities?

1 emerald8 replies60 views
created 10/12/2018 1:56 pm by GabrielBC
last reply 10/13/2018 2:55 pm

I have this modpack that I have been playing for quite a bit of time with minimal problems, and since I changed PCs when I try to join the world, it loads for half a second (even the machine sounds show up) then "Shutting down internal server" appears with the usual dirt background. The game, then, straight up crashes. I read somewhere that this exact problem has to do with mod incompatibilities, so I downloaded this program that checks if mods edit other mods' .class files, or something similar (found at https://www.minecraftforum.net/forums/mapping-and-modding-java-edition/minecraft-tools/1264141-console-app-mod-compatibility-checker-program). I found out that zGraviSuite_1_9_3 edits BetterFurnacesV3's IronEngineFuel.class (and thaumcraft editing a bunch of its own files, but that is probably normal).

-

This has been going on a few months, and I made a previous post about it, stating about how I "removed the portal gun mod mysteriously conflicting with something". I don't remember anything about that, though.

-

Does anyone know how to fix such problem? Help would be immensely appreciated. If you would like additional info, feel free to ask!


https://pastebin.com/FYsThYS8
Posted by avatar
GabrielBC
Level 1 : New Miner
0

8 replies

1
10/12/2018 3:33 pm
Level 19 Journeyman Princess
star_weaver
avatar
download fresh versions or use the latest versions of mods
1
10/12/2018 6:20 pm
Level 1 New Miner
GabrielBC
avatar
If I wanted to I could also go around people's threads telling them to update. Could you please tell me why that would work? (not trying to sound rude or anything)
1
10/12/2018 6:52 pm
Level 19 Journeyman Princess
star_weaver
avatar
cos updated mods work better with each other and have bugs fixed? why else would you update anything?
1
10/12/2018 7:01 pm
Level 1 New Miner
GabrielBC
avatar
Good point, but my goal is to get to play that modded world, not just the mods, so I was looking for an explanation on why the game is crashing based on the crash report as with that I could fix the problem, and continue the playthrough, rather than just updating the mods and having to create another world. And again, not all mods could have newer versions. Thanks for your time, though.
1
10/12/2018 8:20 pm
Level 19 Journeyman Princess
star_weaver
avatar
just aslong as you stay on the same minecraft version, you can add, remove or update mods, only things that will break are the mods that you removed, or world gen for the ones that you added, going from version 1.0 from a mod on minecraft 1.12 to version 2.0 on minecraft 1.12 wont cause much harm unless something massivly changed with how the internal ids changed for the mod
1
10/13/2018 10:24 am
Level 1 New Miner
GabrielBC
avatar
I updated the ones I could, but to no avail. This is really valuable advice nonetheless.

Search

Browse

Site

© 2010 - 2018
planetminecraft.com

Welcome