1

Mod Item Textures Not Working

1 emerald 4 replies 167 views | started 07/20/2017 6:44 pm by benbojangles123
As you can see in the title, the texture for my item that I added with a mod is not working. It shows the large purple and black missing texture square. The only way to get the texture to work is to go into settings, and set the language to English (US), even if it is already selected. I have checked my code several times over. I am making the mod for 1.12.
Posted by avatar
benbojangles123
Level 9 : Apprentice Pokemon
3

4 replies

1
08/15/2017 7:22 pm
Level 1 New Crafter
J_Ditz100
avatar
I am having the same issue. I looked into the console output while running a test and saw that it does the following each time you update the language setting(which I attest does work to make your textures appear):
Spoiler - click to reveal

[18:34:20] [main/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:modid
[18:34:26] [main/INFO]: SoundSystem shutting down...
[18:34:26] [main/WARN]: Author: Paul Lamb, www.paulscode.com
[18:34:26] [Sound Library Loader/INFO]: Starting up SoundSystem...
[18:34:26] [Thread-8/INFO]: Initializing LWJGL OpenAL
[18:34:26] [Thread-8/INFO]: (The LWJGL binding of OpenAL. For more information, see www.lwjgl.org)
[18:34:26] [Thread-8/INFO]: OpenAL initialized.
[18:34:27] [Sound Library Loader/INFO]: Sound engine started
[18:34:34] [main/INFO] [FML]: Max texture size: 16384
[18:34:35] [main/INFO]: Created: 512x512 textures-atlas

The red text appears to be the line in which forge adds your textures to the game. Forge ran this line earlier, but it seems it did not work because you have to make it run it again in order for your textures to appear.

(Note: "modid" is not my mod id, I replaced it)
1
08/06/2017 2:25 pm
Level 72 Legendary Senpai
Soulas
avatar
Watch some tutorials it's quite easy to add in textures almost same thing as in 1.11.2

create some packages like assets.yourmodid.models.item and upload items json file in there and then create another foldier assets.yourmodid.textures.items and don't forget to register render for your items.
1
07/21/2017 6:52 am
Level 51 Grandmaster Programmer
QuickScoP3s
avatar
Can you show us some code, please?
1
07/20/2017 7:41 pm
Level 1 New Crafter
WilliamRFlagg
avatar
"benbojangles123"As you can see in the title, the texture for my item that I added with a mod is not working. It shows the large purple and black missing texture square. The only way to get the texture to work is to go into settings, and set the language to English (US), even if it is already selected. I have checked my code several times over. I am making the mod for 1.12.

Maybe Try using MCreator?
They have a version for 1.11.2
Checking to make sure they have it for 1.12.......
Nevermind Dont use mcreator they only have it for 1.11.2

Search

Browse

Site

© planetminecraft.com

Welcome