Minecraft Mods

OpenGL Patch

  • 127,159 views, 36 today
  • 19,747 downloads, 2 today
  • 22
  • 16
  • 126
SierraHawk avatar SierraHawk
Level 54 : Grandmaster Zombie
20
Patch description

This mod contains a patch that removes functions and features from the game using the OpenGL graphics library version greater than 1.4. Therefore disappear from the game shaders and all special graphics effects which require OpenGL 2.1.

How use it?

For easy application of the patch I recommend you use Magic Launcher.

PlatformDownload Link
Windowshttp://adf.ly/404181/magiclauncher.com/adloadx.php?f=MagicLauncher_1.3.2.ex
MAChttp://adf.ly/404181/magiclauncher.com/adloadx.php?f=MagicLauncher_1.3.2.zip
Linuxhttp://adf.ly/404181/magiclauncher.com/adloadx.php?f=MagicLauncher_1.3.2.jar


More about issue /w OpenGL:

http://minecraftforum.net/forums/minecraft-discussion/recent-updates-and-snapshots/381729-old-graphics-card-snapshot-13w38c

How to determine version of OpenGL:
  1. Check the model of graphics card and visit manufacturer's website to determine the supported version of OpenGL.
  2. Install a special (i.e. GLview 4.1)http://www.realtech-vr.com/glview/download.php

Download
Patch VersionDownload Link
OpenGL Patch for 1.7.10http://www.mediafire.com/download/89hz8gj8zh54utn/OpenGL_Patch_for_1.7.10.zip
OpenGL Patch for 1.8http://www.mediafire.com/download/f050l9a4en0h034/OpenGL_Patch_for_1.8.zip
OpenGL Patch for 1.9.4http://www.mediafire.com/download/o6bs27fcznr206k/OpenGL_Patch_for_1.9.4.zip
OpenGL Patch for 1.10http://www.mediafire.com/download/mba8d4k9czyy2i9/OpenGL_Patch_for_1.10.zip

Tutorial | How to apply OpenGL patch
Progress100% complete
Game VersionMinecraft 1.10
Tags

3 Update Logs

Version 1.10A : by SierraHawk 06/26/2016 3:48:54 pmJun 26th, 2016

  • Removed all shaders components
  • Disabled VBO buffering
  • Compatible only with Minecraft 1.10

LOAD MORE LOGS

Create an account or sign in to comment.

1
09/13/2017 1:41 am
Level 29 : Expert Nerd
TapuCocoa
TapuCocoa avatar
1.8.9?
1
06/06/2017 6:13 pm
Level 1 : New Miner
Bheryl
Bheryl avatar
Any chance anyone might be able to help me with this?
1
04/05/2017 12:56 am
Level 1 : New Miner
Bheryl
Bheryl avatar
When I install this with Magic Launcher is says that the patch is not compatible as well. The 1.8 patch works perfectly fine but 1.9 and 1.10 do not, and I've tried to install them manually and they also seem to not work and I just crash.




I said this before on an account that I lost access too and I also said I still crash even when trying to install it anyway. Any chance I could get some help with this?
1
04/05/2017 1:20 am
Level 1 : New Miner
Bheryl
Bheryl avatar
Here's the crash log in case it helps


*** MagicMinecraftLauncher 1.3.4 ***
LCP: ;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\mojang\netty\1.6\netty-1.6.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\oshi-project\oshi-core\1.1\oshi-core-1.1.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\net\java\dev\jna\jna\3.4.0\jna-3.4.0.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\net\java\dev\jna\platform\3.4.0\platform-3.4.0.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\ibm\icu\icu4j-core-mojang\51.2\icu4j-core-mojang-51.2.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\net\sf\jopt-simple\jopt-simple\4.6\jopt-simple-4.6.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\paulscode\codecjorbis\20101023\codecjorbis-20101023.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\paulscode\codecwav\20101023\codecwav-20101023.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\paulscode\libraryjavasound\20101123\libraryjavasound-20101123.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\paulscode\librarylwjglopenal\20100824\librarylwjglopenal-20100824.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\paulscode\soundsystem\20120107\soundsystem-20120107.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\io\netty\netty-all\4.0.23.Final\netty-all-4.0.23.Final.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\google\guava\guava\17.0\guava-17.0.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-lang3\3.3.2\commons-lang3-3.3.2.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\commons-io\commons-io\2.4\commons-io-2.4.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\commons-codec\commons-codec\1.9\commons-codec-1.9.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput\2.0.5\jinput-2.0.5.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\net\java\jutils\jutils\1.0.0\jutils-1.0.0.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\google\code\gson\gson\2.2.4\gson-2.2.4.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\mojang\authlib\1.5.22\authlib-1.5.22.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\com\mojang\realms\1.9.1\realms-1.9.1.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\apache\commons\commons-compress\1.8.1\commons-compress-1.8.1.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\apache\httpcomponents\httpclient\4.3.3\httpclient-4.3.3.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\commons-logging\commons-logging\1.1.3\commons-logging-1.1.3.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\apache\httpcomponents\httpcore\4.3.2\httpcore-4.3.2.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\it\unimi\dsi\fastutil\7.0.12_mojang\fastutil-7.0.12_mojang.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\apache\logging\log4j\log4j-api\2.0-beta9\log4j-api-2.0-beta9.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\apache\logging\log4j\log4j-core\2.0-beta9\log4j-core-2.0-beta9.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl\2.9.4-nightly-20150209\lwjgl-2.9.4-nightly-20150209.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl_util\2.9.4-nightly-20150209\lwjgl_util-2.9.4-nightly-20150209.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\org\lwjgl\lwjgl\lwjgl-platform\2.9.4-nightly-20150209\lwjgl-platform-2.9.4-nightly-20150209-natives-windows.jar;C:\Users\Jose\AppData\Roaming\.minecraft\libraries\net\java\jinput\jinput-platform\2.0.5\jinput-platform-2.0.5-natives-windows.jar;C:\Users\Jose\AppData\Roaming\.minecraft\versions\1.10GL\1.10GL.jar
ShowLog: true
InactiveExtMods: OpenGL Patch for 1.10 (3).zip
McVersion: 1.10
MainClass: net.minecraft.client.main.Main
Restoring disabled mods: mods
Restoring disabled mods: mods/1.10
Disable inactive mods: mods
Disabled: OpenGL Patch for 1.10 (3).zip
Restoring disabled mods: coremods
Restoring disabled mods: coremods/1.10
Disable inactive mods: coremods
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at magic.launcher.Launcher.main(SourceFile:214)
Caused by: java.lang.SecurityException: SHA-256 digest error for bcx.class
at sun.security.util.ManifestEntryVerifier.verify(Unknown Source)
at java.util.jar.JarVerifier.processEntry(Unknown Source)
at java.util.jar.JarVerifier.update(Unknown Source)
at java.util.jar.JarVerifier$VerifierStream.read(Unknown Source)
at sun.misc.Resource.getBytes(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at net.minecraft.client.main.Main.main(SourceFile:39)
... 5 more
1
08/06/2016 10:13 pm
Level 16 : Journeyman Taco
JosEffigy
JosEffigy avatar
I realized all these comments were made 1 year ago. Forge compatibility should be the first thing that comes since I can run all minecraft vanilla fine without opengl 2 but not on forge which should be priority.

any news?
1
07/28/2016 7:36 am
Level 1 : New Miner
nkkiller
nkkiller avatar
Does this work for mod? I want to play pixelmon in 1.7.10 :/
1
07/18/2016 8:13 pm
Level 3 : Apprentice Crafter
BerserkerRace
BerserkerRace avatar
Is there anyway you can help me with this? A server I am a staff member on is planning on moving on from 1.8 and thats the only patch that works for me.
1
07/07/2016 1:00 am
Level 3 : Apprentice Crafter
BerserkerRace
BerserkerRace avatar
When I install this with Magic Launcher is says that the patch is not compatible as well. The 1.8 patch works perfectly fine but 1.9 and 1.10 do not, and I've tried to install them manually and they also seem to not work and I just crash.
1
07/10/2016 3:40 am
Level 54 : Grandmaster Zombie
SierraHawk
SierraHawk avatar
Try to install even if it reports that it is incompatible. Magic Launcher just can't recognize the version of Minecraft versus patch version.
1
07/10/2016 1:24 pm
Level 3 : Apprentice Crafter
BerserkerRace
BerserkerRace avatar
I've tried that and it still crashes.
Planet Minecraft

Website

© 2010 - 2022
www.planetminecraft.com

Welcome