228
Minecraft / Mods

[WIP] Harry Potter Mod 1.12.1 [FORGE] (FINALLY UPDATED)

Collectable
  • 243,084
    Views, 154 today
  • 71,033
    Downloads, 43 today

Get Embed Codes

Forum:
HTML:
Link:
avatar
maxgjones121
Level 62 : High Grandmaster Modder
95

Hey guys!


I have decided to continue developing the Harry Potter Mod from where i left off two years ago. I plan on implementing many new and exciting features related to the series in the future, I hope you enjoy the mod!



CURRENT FEATURES:




INSTALLATION


1. You will need to download and install Minecraft Forge 1.12.1, you can do so here: https://files.minecraftforge.net/

2. Run the game once with the new profile created by forge.

3. In the search directory of your computer type "run".

4. In the dialogue box, type "%appdata%" and click run.

5. Navigate to the ".minecraft" folder and drag the downloaded .jar file of this mod into the folder called "mods".

6. Run the game and enjoy the mod!

NOTE: This mod is a work in progress and is by no means completed:
  • If you have any suggestions for future features or are interested in joining in the development of this mod and are an experienced modder contact me!
  • If you experience any bugs/errors/spelling mistakes etc. please also let me know so i can fix these!

** If for some reason the above download link does not work, here is an alternative download link: http://www.mediafire.com/file/2ro46do51b8adl7/HarryPotterMod-1.0.jar
Progress: 30% Complete
Game Version:Minecraft 1.12

Version 1.1 : 09/13/2017 10:54:15 am9/13/17

+ Added 2 new mobs:
  • Dementor
  • Death Eater
+ Added 2 new spells:
  • Sectumsempra
  • Wingardium Leviosa
* Fixed issue where players would receive first join guide book every time they logged into a world.
* Fixed issue where in-game HUD of the currently used spell would not adjust to non-full screen windows of the game.

Update #8 : 09/06/2017 11:11:56 am9/06/17

Picked up where I left off :)

Update #7 : 10/14/2012 12:43:04 am10/14/12

added two mod spotlights that are great! :))

Update #6 : 10/03/2012 12:16:31 am10/03/12

- Fixed a bug :)

Update #5 : 10/02/2012 9:40:24 pm10/02/12

You can now click the 'R' button to change between spells



Much MORE

Update #4 : 09/16/2012 6:38:11 am9/16/12

- Added a recipe picture

- added the video

Update #3 : 09/16/2012 4:02:19 am9/16/12

Added Features: !

- Elder Stick

- Randomly Generated Elder Tree

- New wand(spell) Avada Kadavra

Update #2 : 09/15/2012 9:43:53 am9/15/12

- Added a mod spotlight!! :D

Update #1 : 09/13/2012 1:27:51 am9/13/12

Features Added:

- Chocolate Frogs

- Slice Of Pumpkin

- Chocolate Drop

- Pumpkin Juice

- ButterBeer

- Pumpkin Pastie

Comments : 623

Join us to post comments.

Show Comments

1 - 50 of 623

  • Hogwarts_
  • Level 24
  • Expert Architect
  • September 16, 2017, 9:06 am
Hey I`m a Huge HP fan and a good 3D Modeler "JSON" and would Love to Join, already have some Harry Potter 3D Models 4 you xD
  • AestasLaFox
  • Level 1
  • New Explorer
  • September 13, 2017, 8:02 am
The new updates awesome! I love the Dementor and Death Eater models.
  • maxgjones121
  • Level 61
  • High Grandmaster Modder
  • September 13, 2017, 8:19 pm
Thank you so much! Hope you are enjoying the mod so far :)
  • AestasLaFox
  • Level 1
  • New Explorer
  • September 14, 2017, 9:36 am
Yeah! It's great.
  • AestasLaFox
  • Level 1
  • New Explorer
  • September 11, 2017, 11:22 am
It's great that you're working on this again! I have a suggestion though. Make it so Lumos makes light come out of the tip of the wand. Like in the Books/Movies.
  • maxgjones121
  • Level 61
  • High Grandmaster Modder
  • September 11, 2017, 7:27 pm
Thankyou! Yes you're right that would be great, it is a feature i will hopefully be working on later down the track as it is really hard to code moving light sources in Minecraft. For some reason Minecraft does not support this on its own without some serious coding :( but watch this space :)
  • Vlekkeloos
  • Level 26
  • Expert Explorer
  • September 8, 2017, 5:00 am
Good to see that you came back, curious to see what you will continue to add ;)
  • maxgjones121
  • Level 61
  • High Grandmaster Modder
  • September 11, 2017, 7:20 pm
Thankyou! Well hopefully it will be a lot of cool features ! the next update will see some new mobs that i am currently working on now (dementor and death eater).
  • Vlekkeloos
  • Level 26
  • Expert Explorer
  • September 12, 2017, 7:43 am
Nice, I am planning to make a showcase of this mod soon ;)
  • maxgjones121
  • Level 61
  • High Grandmaster Modder
  • September 12, 2017, 8:18 am
That would be awesome! Please let me know if you do :) I am hoping to have the next update out within the next 4 days.
  • Vlekkeloos
  • Level 26
  • Expert Explorer
  • September 12, 2017, 10:51 am
No need to hurry sir, I have a lot of mods planned to record, will put yours around top of list ;)
do we ned to use minecraft version 1.3.3 .-. like we passed that update
How do i unzip this using WinZip, there are somany .class files, and items and gui and stuff, i dont understand how to make it work in the mods folder. Can anyone help?
Can you have it so that expelliarmus will make the mob DROP the weapon so that like a skeleton will drop its bow? And instead of a cobweb where we have to break the cobweb, for stupefy, have it so that it gives a slowness effect?
And Avada Kedavra is kinda stupid cuz it is supposed to kill. It is KINDA, maybe A LOT overpowered but it still needs that killing effect. But also add Voldemort and have it so that he is a boss. Make it so that you can't kill Voldemort unless you use Expelliarmus and you have to spam a certain key.
Sky sent me
me too
PLEASE UPDATE for Version 1.7 !!!
What version this mod want's on every version or the forge can't see that mod or minecraft crashs
  • kyle_mine2
  • Level 2
  • Apprentice Miner
  • July 23, 2014, 2:56 am
This is what i get:

Crash
  • kyle_mine2
  • Level 2
  • Apprentice Miner
  • July 23, 2014, 2:33 am
I cant seem to find modloader...
Still AWSOME MOD!!!
+1 Shiny for you!!
update
guys this mod is dead
Are there Dragons or Thestrals?
does it need forge?
UPDATE PLZZZ!
PLEASE MODIFY FOR 1.7. PRETTY, PRETTY PLEASE. THIS IS THE BEST HARYY POTTER MOD OF ALL TIME & I'M A MASSIVE HARRY POTTER FAN. PLEASE UPDATE!
Update ASAP.
  • _Skydiver
  • Level 5
  • Apprentice Engineer
  • February 28, 2014, 9:20 pm
This mod is dead
  • brickman940
  • Level 16
  • Journeyman Nerd
  • December 12, 2015, 5:10 pm
sadly, yes. may this mod rest in piss.
  • furballswift
  • Level 2
  • Apprentice Crafter
  • February 23, 2014, 9:47 am
you should have more wands like for example hermiones ginnys and harrys ect.
  • Shouvik12
  • Level 1
  • New Explorer
  • February 22, 2014, 4:21 pm
Sky sent me :)
1.6.4 pl0x,
Voldemort should be a boss
And if you can, I think you should like make Filch and Peeves bosses at night (Specifically at night).

And you should have like Diagon Ally my man, diamond for you if this could be added lol pl0x :3 (With all the stores and weapons and stuff)
You should also have pets. And Money!
Omg bro this was like a year ago, I don't think you are going to update this or even work on it anymore. I don't think you even play Minecraft anymore, but I have more suggestions if you can reply to me and still say your working on it.
  • Esma
  • Level 1
  • New Miner
  • February 18, 2014, 4:17 pm
Voldemort, Peeves, and Filch should be Bosses.

You should also add firewhisky, maybe Hedwig, Pigwideon.
You should also try the spell Hermione used for blue fire.

thx!
Please update to 1.6.4!!!
  • EskoXY97
  • Level 9
  • Apprentice Taco
  • February 9, 2014, 11:30 am
Update! Please!
  • myruthb
  • Level 1
  • New Miner
  • January 30, 2014, 2:21 pm
Sky sent me. Can you make it forge compatible? also, you should add a new mob such as Hedwig (can be tamed with pumpkin slice), 1.6.2 PEOPLE!, also maybe add like a quest book and a certain seed for it, maybe add some death eaters, and maybe bosses?
  • honaay
  • Level 1
  • New Miner
  • January 18, 2014, 6:30 am
PLS Update D:
  • Esma
  • Level 1
  • New Miner
  • January 7, 2014, 3:43 am
LOVE IT! DIAMOND FOR YOU PRO MOD MAKER!!!!!!!
no its not
is it compatible with forge?
  • TudorOstrich
  • Level 15
  • Journeyman Goblin
  • October 27, 2013, 9:57 am
Guys, nobody gives a damn who sent you. Just shut up and enjoy the mod >.>
  • mariushb03
  • Level 2
  • Apprentice Miner
  • October 24, 2013, 7:41 am
be for 1.6.4
  • kazi404
  • Level 1
  • New Miner
  • September 27, 2013, 2:08 pm
1.6.2!!!!!!!!!! this mod is out dated and no one play 1.3.2 any more and Sky sent me
  • Withah_Killah
  • Level 8
  • Apprentice Skinner
  • September 15, 2013, 5:36 am
just use old launcher and MVC to 1.3.2 download modloader for 1.3.2
  • brickman940
  • Level 16
  • Journeyman Nerd
  • September 20, 2013, 4:17 pm
bvfgbjhdgrebger
  • brickman940
  • Level 16
  • Journeyman Nerd
  • September 13, 2013, 4:48 pm
i need 3 things for this mod: 1.6.2, forge compatible, and make the Expelliarmous spell strong enough to combat the most destructive spell: Avada Kadavra. and sky sent me.
SKY SENT ME!!!!!!!!!!!!!
  • JeddMiner
  • Level 2
  • Apprentice Miner
  • August 25, 2013, 9:07 am
Guys, the reason it is taking so long is that he needs to change it to 1.6.2, fix bugs, add lots of stuff, AND convert it to forge, that takes a lot of time, so just be patient.
  • JeddMiner
  • Level 2
  • Apprentice Miner
  • August 20, 2013, 10:25 am
MAKE FOR 1.6.2 PLEASE!!!!
  • Dsguy2000
  • Level 1
  • New Miner
  • August 15, 2013, 6:29 am
sky sent MEH

make forge aswell
MAKE IT FORGE COMPATIBLE !!!
1.6.2 and forge please
Doesn't work
  • leon6er
  • Level 2
  • Apprentice Explorer
  • July 28, 2013, 11:02 am
update
Plz 1.5.2, PLZZZZZZZZ!
  • Valcapo10
  • Level 1
  • New Crafter
  • October 4, 2013, 3:31 pm
YEA!!!
Sky sent me
1.6.2 can't wait :)
  • VALERock
  • Level 1
  • New Explorer
  • July 4, 2013, 4:45 am
Sky sent me here.
AWESOME!!!
  • Flixnore
  • Level 4
  • Apprentice Explorer
  • June 26, 2013, 1:20 pm
Is t compatible with Forge?
nice i love harry potter the book this is a new start
  • yaja
  • Level 12
  • Journeyman Toast
  • June 18, 2013, 4:26 am
is there and 1.2.5 version
I can't wait until this mod is finally updated to 1.5.2! Do you have an idea of when this would happen? Thanks.
Are you having trouble with the wands? Does it look like the effect happened, but it didn't and it gets glitchy (especially when walking into a hole from an explosion)? I am having trouble with that too.
  • maxgjones121
  • Level 61
  • High Grandmaster Modder
  • May 27, 2013, 11:35 pm
Hey man are you using this on 1.3.2? If you are then don't worry this is just a bug but I am bringing out an updated version for 1.5.2 soon which will not have this bug :)
Actually I have never used this mod. I was just curious if you have had trouble with what I described. I mod some too and it has broken some of my magic wands. Minecraft 1.4 did that.
1.5.2 plz!!!!!!!!!!!!!!!!!!
I want to got this mod, but i heard its work for 1.3.2, did anybody know how to get minecraft back to 1.3.2 sorry for my bad english, im from germany, i want this mod so much !! But if i download it, theres a black screen, minecraft crashed, or a load screen, PLEASE HELP

(My minecraft is 1.5.2)
  • Lilalvin
  • Level 33
  • Artisan Creeper Hugger
  • May 8, 2013, 2:50 pm
You need to downgrade, but the creator said he is working on updating it. But if you REALLY want the mod now, here are the instructions.
1. Google: Minecraft jar 1.3.2
2. download
3. go to %appdata%
4.go to .minecraft
5.bin
6.delete minecraft.jar and replace with 1.3.2 jar
7. Check and make sure minecraft works
8. follow the instructions to install mod
Hope this works!
  • WolfGirl7777
  • Level 5
  • Apprentice Architect
  • May 4, 2013, 8:05 pm
Well, if it is going to stay in 1.3.2, I will treat it like that. OUTDATED D:
Sky sent me.

1 - 50 of 623

Show Comments

Search

Browse

Site

© planetminecraft.com

Welcome