Forumskeyboard_arrow_right Minecraft - Java Edition keyboard_arrow_right Modding

Create Forum Thread
2

How to Update a 1.12.2 mod to 1.14(.4)?

2 emeralds14 replies1,770 views
created 07/31/2019 5:00 pm by AwesomeNinja886
last reply 09/20/2019 1:02 pm
I wanted to create a mod with MCreator, but it won't support 1.14.4 until the full release of Forge for 1.14.4, and by that time 1.15 may already be old news. So, I resolved to try and make it in MCreator and then update it to 1.14.4 afterwards, a slight but necessary inconvenience. However, I have a big problem: all of the tutorials on how to update mods are outdated. So, how do I do it?
Posted by avatar
AwesomeNinja886
Level 20 : Expert Ninja
10

comment Login or register to post a reply.

14 replies

2
09/19/2019 7:48 pm
Level 7 : Apprentice Crafter
RoRayzip
open Minecraft with only your mod then smack your Computer with a bat for a min then light it on fire, buy a now computer and it will be updated
1
09/20/2019 1:02 pm
Level 20 : Expert Ninja
AwesomeNinja886
No, I don't think so.
2
09/19/2019 7:55 amhistory
Level 58 : Grandmaster Terraformer
Myyoyo
Wait until there's MCreator for 1.14.4, then open and resave your 1.12.2 MCreator mod file in the 1.14.4 MCreator.
1
09/15/2019 8:40 pm
Level 1 : New Miner
hehhe
the full release for forge 1.14.4 recently released and is available
2
07/31/2019 6:22 pm
Level 25 : Expert Artist
Vaux1te
the code is different from each version, so you have to create the mod all over again.
1
08/27/2019 2:20 am
Level 1 : New Miner
hehhe
yeah the code is different but similar also if you want to port a mod eclipse might be better as it will tell you the error and correct it
also, you need an mdk so you download that from the forge website
2
08/01/2019 8:23 pm
Level 20 : Expert Ninja
AwesomeNinja886
That stinks...

But people have updated mods from ≤1.5 to 1.6, and other versions, but I'm not seeing a tutorial for 1.12(.2) to 1.14(.4). I'd be fine if I had to port it to 1.13 first and then to 1.13.2 and then to 1.14 and then to 1.14.4, if that's necessary.
1
08/01/2019 8:53 pm
Level 25 : Expert Artist
Vaux1te
maybe because it would take a long time, since you need to learn the code for the new version, and create the mod all over. I also dont think they have one for 1.13 to 1.13.2 to 1.14 to 1.14.4.
1
08/02/2019 8:34 am
Level 20 : Expert Ninja
AwesomeNinja886
OK...

I literally said:
"people have updated mods from ≤1.5 to 1.6, and other versions, but I'm not seeing a tutorial for 1.12(.2) to 1.14(.4)"

My question is, how would you do it for newer versions (i.e. 1.12(.2) to 1.14(.4))? There's YouTube tutorials for updating mods to new versions, but they're all outdated.

I was saying about the 1.13 -> 1.13.2 -> 1.14 -> 1.14.4 because I am fine if I need to take extra steps to do that (port to other versions before 1.14.4).
1
09/15/2019 2:57 amhistory
Level 35 : Artisan Wolf Whisperer
Trhod177
you cant because the internal changes between 1.12.2 and 1.14.4 are far greater then the internal changes between <1.5 and 1.6.
1
09/19/2019 6:03 am
Level 1 : New Miner
Paprcuts
There's still a way to do so though right? I don't see any tutorials online though
1
08/04/2019 4:44 pm
Level 25 : Expert Artist
Vaux1te
im not sure.

Planet Minecraft

Browse

Site

© 2010 - 2019
www.planetminecraft.com

Welcome