Minecraft / Mods

Minecraft Version Swapper 2.0

  • 55
  • 19
  • comment100
  • playlist_add
  • share
  • more_horiz
avatar martin2250
Level 53 : Grandmaster Pyro
117
Minecraft Version Swapper is a little Tool (windows only, mac will probably never be supported -sorry-) to quickly switch between 10 different versions of minecraft (eg "1.2.5", "1.2.5 with mods" "old version" etc.) after you have installed it you just have to click a button to select your version

If you want to look at the source code, just send me a pm with your e-mail and the reason you want it ;)

the second version of this program features 10 versions to choose from, a new improved GUI

since the first version of this mod was so sucessful and i needed more than 5 versions i decided to make another version

the program itself was completely re-coded and written in c#

i spent more than 4 days on making this program perfect, so please leave a diamond if you like it and/or leave a comment with constructional criticism

the image in the middle was rendered in blender(http://www.blender.org/)

PREPARE FOR VERSION 3!! (out in a few days)

another tutorial:
Progress100% complete
Game VersionMinecraft 1.3.1
Tags

1 Update Logs

Bugfix -fixed error when selecting non existing version- : 06/15/2012 12:26:45 pmJun 15th, 2012

fixed error when selecting non existing version

Comments : 100

star Login or register to post a comment.

Show Comments

1 - 50 of 100

  • Tank111
  • Level 1
  • New Miner
  • December 16, 2012, 1:33 am
ive used this before and is on a windows 7 and it dosent want to replace the minecraft.jar(the version 4 didnt work either)
EDIT: I forgot to put some scrap in slot 3, 4 and 5
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • December 16, 2012, 3:31 am
i hope you know that you have to use whole .minecraft folders, not only jars...
  • Tank111
  • Level 1
  • New Miner
  • December 24, 2012, 6:37 am
ive used this before -.-
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • December 24, 2012, 11:43 pm
whoops, sorry :(
  • Goofygirl27
  • Level 6
  • Apprentice Blacksmith
  • September 13, 2012, 7:16 am
Does this work for Mac?
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • September 13, 2012, 8:29 am
yeah, exe files will definetely work on a mac :D
  • Goofygirl27
  • Level 6
  • Apprentice Blacksmith
  • September 20, 2012, 3:52 pm
.exe don't work on Mac
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • September 21, 2012, 3:05 am
ever heard of something called irony?
  • Goofygirl27
  • Level 6
  • Apprentice Blacksmith
  • September 22, 2012, 5:07 pm
nope
  • TheBluekid
  • Level 1
  • New Miner
  • August 17, 2012, 6:47 pm
Hey martin sorry i haven't anserwed back in a while but nice and improved vid, got one question Does it need to update?
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 18, 2012, 7:08 am
what do you mean, if the new video is a newer version? - no, it's the same version as you could download 2 months ago
  • NiC0L3 R0CKS
  • Level 6
  • Apprentice Explorer
  • August 4, 2012, 2:41 pm
Where is the link on this page to download?
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 5, 2012, 2:46 am
it's the File Mirror
  • wdfitzpat2
  • Level 1
  • New Miner
  • August 3, 2012, 12:30 pm
So you need the older versions? Because I only have 1.3.1 and need 1.2.5!!!!!
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 4, 2012, 12:21 am
you don't need older versions you can also just make a version with/without mods

also if you played minecraft in 1.2.5, there should be a "minecraft 1.2.5.jar" in you bin folder rename that to minecraft.jar and you have 1.2.5
  • chocpup08
  • Level 1
  • New Miner
  • August 3, 2012, 3:57 am
i cant use it becouse i only have 1 vesion
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 3, 2012, 4:19 am
then why don't you just get other version ;)
  • chocpup08
  • Level 1
  • New Miner
  • August 11, 2012, 9:08 am
now i know what it is i have a cracked minecraft. becouse my old acount got hacked and know i cant log in
  • smeetie2
  • Level 21
  • Expert Pony
  • August 3, 2012, 2:49 am
I LUV U!
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 3, 2012, 4:19 am
<3 ;)
  • smeetie2
  • Level 21
  • Expert Pony
  • August 3, 2012, 5:36 am
Wait.... how do i work this :
by the way ur server generator doesent work when i set the ip to MrSuperiron22.com and it said cant resolve host name
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 2, 2012, 1:38 am
seriously, are you kidding me?
go in the corner and be ashamed ;)

do NOT change the textbox "ip", unless you really know what you're doing
WHY SHOULD I BE ASHAMED
  • Urwaldzwerg
  • Level 15
  • Journeyman Warrior
  • August 2, 2012, 12:18 am
I did everything like the video but it dosent work on my win7 of xp need help
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 2, 2012, 1:38 am
then tell me what did not work, i cant help you right now
  • Urwaldzwerg
  • Level 15
  • Journeyman Warrior
  • August 2, 2012, 1:55 am
dosen't matter any more got everything handled now
  • robert9858
  • Level 1
  • New Explorer
  • August 1, 2012, 12:10 pm
do you need the jar?!?
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • August 1, 2012, 11:23 pm
what do youn mean by that?
  • robert9858
  • Level 1
  • New Explorer
  • August 3, 2012, 1:23 pm
you need to put the minecraft jar
  • psyqoze
  • Level 1
  • New Crafter
  • July 16, 2012, 3:36 pm
In v3.0 do you think it will be possible to make it so when you click on a version in will open it, instead of clicking a version to use, then opening the minecraft client?
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • July 17, 2012, 3:20 am
there is already a version 3, but the idea is good
  • psyqoze
  • Level 1
  • New Crafter
  • July 17, 2012, 1:50 pm
why is there no link? This makes me sad :(
  • getekstis
  • Level 13
  • Journeyman Architect
  • July 11, 2012, 9:00 am
You are like a god for me!!
  • Kjordo711
  • Level 43
  • Master Lad
  • July 5, 2012, 11:42 am
you use Visual Basic right? thats why you cant go mac? i recommend Java. its a great way to go universal
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • July 12, 2012, 3:47 am
i don't know if other systems will support it becaus you have to use junctions, also i can' program jva and its not visual basic but c#
  • jhgfdsa176
  • Level 6
  • Apprentice Warrior
  • July 1, 2012, 12:35 am
Very Good.
Love this program works very well
Got all my clients in there
keep up the good work :)
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • July 1, 2012, 12:55 am
thanks :D
  • jhgfdsa176
  • Level 6
  • Apprentice Warrior
  • July 1, 2012, 1:29 am
No problems :)
  • SjefsSt3kare
  • Level 16
  • Journeyman Pokemon
  • June 22, 2012, 1:01 am
make older versions ?
like beta
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 22, 2012, 3:59 am
NO!
this tool doesn't change versions, it only can manage multiple .minecraft folders!
Hey a so when whens version 3 comming out
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 17, 2012, 7:37 am
i'm almost finished, adding some final touches to the ui, but i'm not entirely sure if it will be better than V2
  • TalonOTSH
  • Level 10
  • Journeyman Ninja
  • June 16, 2012, 2:27 pm
can u make it for mac?
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 17, 2012, 12:36 am
stop f*cking asking read the description!!!
why did my sonar scan say it had a virus
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 17, 2012, 12:37 am
don'T know, maybe because it creates some .bat files, if you don't trust me send me a pm with your email and i'll send you the source code
Its OK, Ill Just Give A Diamond And Subscribe.

P.S. I Was Using Norton Antivirus.
It WAY Overreacts Sometimes.
  • Citralhq
  • Level 1
  • New Blacksmith
  • June 16, 2012, 10:17 am
Dang, I made a promise to myself that I'd beat you.... Your way ahead of me I had 24 diamond when you had 20 tho... I have 26 now -.-
  • troytaylor2
  • Level 18
  • Journeyman Prince
  • June 16, 2012, 10:04 am
tryed dindt work on the older or this i have a windows
  • WiseWoodrow
  • Level 12
  • Journeyman Blacksmith
  • June 16, 2012, 9:36 am
I have a question before I download and use:

What happens if I play a saved world,
using a old version of minecraft?
(AKA what if that version didn't have some of the features of the current version?)

I would like to know this.
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 17, 2012, 12:38 am
you can't load a new world in an old version of minecraft, worlds are seperated for each version
  • WiseWoodrow
  • Level 12
  • Journeyman Blacksmith
  • June 17, 2012, 8:17 am
Thanks. Hped so.
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 17, 2012, 8:22 am
no prob :)
  • troytaylor2
  • Level 18
  • Journeyman Prince
  • June 16, 2012, 9:42 am
dude you still can only diffrence is that item's that arnt in that vershion will be gone
  • theripelemon
  • Level 49
  • Master Dragonborn
  • June 16, 2012, 4:37 am
OMFG U ARE A GOD!
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 16, 2012, 4:46 am
not quite ;) thanks :)
  • Smool6
  • Level 21
  • Expert Archer
  • June 16, 2012, 3:19 am
Go Nahui!
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 16, 2012, 4:46 am
dafuq is nahui?
  • Smool6
  • Level 21
  • Expert Archer
  • June 16, 2012, 10:04 am
Go Nahui, means Go on!
  • martin2250
  • Level 53
  • Grandmaster Pyro
  • June 17, 2012, 12:41 am
thanks :)

1 - 50 of 100

Show Comments

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome