Minecraft / Mods

Snips' Weapons Mod (BETA)

  • 46 Diamonds
  • 43,501 views, 102 today
  • 17,821 downloads, 42 today
  • 38 comments
  • 36 favorites
  • 46
  • 36
  • comment38
  • playlist_add
  • share
  • more_horiz
avatar Luukn123
Level 43 : Master Modder
22
Hi! I'm Snips AKA Luukn123.
I've made this weapon mod containing:
AK74
FNFal
SW1911
MP5
More coming soon...

This mod is currently in the BETA!
Report bugs in the comments or mail to [email protected].
Thanks!

Updates:
1.1.0
- Added AK74
- Added SW1911
- Added custom creative tab
- Added FNFAL
- Added MP5
- Added Offhand Support.
- Added M40
- Added M16

1.1.5
- Added UMP
- Added P30
- Added Achievement
- Added PKP
- Added AK74u

1.2.0
- Added some useful commands.

1.2.5
- Added custom bullet.

1.3.1
- Added more armor.





- I've rewritten the whole mod to fix some bugs. If you're running 1.3.1 or earlier, I recommend downloading it again.


Progress35% complete
Game VersionMinecraft 1.12.2
Tags

38 replies

1
05/10/2019 7:21 pm
Level 1 : New Miner
pwsf2
the download link takes me to freenom.link

can someone help me actually download it?
1
02/04/2019 3:09 am
Level 1 : New Miner
FMPPS
I hope to have a Chinese language
1
01/14/2019 9:12 pm
Level 1 : New Miner
Dallas421
I dont know what mc version I have except for the information thing : 1.84 So yeah. :/ please help.
1
04/14/2019 8:56 pm
Level 1 : New Miner
alexcraft12
the version is 1.12.2 recommended!
1
01/03/2019 1:10 pm
Level 1 : New Miner
Atari_2600
Hello Can u please add aiming down the scopes/iron sights also it would be great if you add reloding and recepies


1
11/29/2018 5:12 am
Level 1 : New Miner
black_platinum

before i install this mod

can you aim down scope

and also im hoping the gun recoil aint too much

last time i installed a similar mod the recoil was horrible
1
10/21/2018 10:09 pm
Level 1 : New Miner
TheSwordsManROBLOXonYT
help i cant add resource packs plz someone help my version is 1.12.1 or 1.12.2 i tried at 1.12.2 but no resource pack is in now i tried 1.12.1 with a different folder but with the same .jar files but no guns are showing up, help!

if you know anything for how to do it, please reply or send a mail to my gmail: [email protected]

thx

1
04/17/2019 12:47 pm
Level 1 : New Explorer
EnderYTV
pls just find out how you install mods before i lose more braincells.
1
04/14/2019 8:58 pm
Level 1 : New Miner
alexcraft12
it is not a resource pack you need to put it in the mods folder. if the mods folder doesn't show up create a new folder and call it mods, if you don't have forge for 1.12.2 install that and open it with java.
1
09/02/2018 8:16 pm
Level 1 : New Miner
mikecraftpro101
hi

1
04/17/2019 12:47 pm
Level 1 : New Explorer
EnderYTV
hi
1
09/23/2018 4:03 pm
Level 43 : Master Modder
Luukn123
hi
1
07/16/2018 1:01 pm
Level 1 : New Miner
Willok
first of all, what a cool mod dude, nice work. second, can you think about adding old weapons too? like flintlock pistols or muzzle loaded rifles?
1
06/18/2018 6:30 pm
Level 5 : Apprentice Network
Boss Youtuber
what mc version
2
07/07/2018 2:33 pm
Level 1 : New Explorer
DubYT
It clearly says "1.12.2"
1
06/09/2018 10:21 pm
Level 1 : New Miner
Din0saurDan
Are there currently crafting recipes for this? Or are they going to be added later
1
06/12/2018 4:31 pm
Level 43 : Master Modder
Luukn123
Im planning on adding them at a later point.
1
05/13/2018 5:10 am
Level 43 : Master Modder
Luukn123
- I've rewritten the whole mod to fix some bugs. If you're running 1.3.1 or earlier, I recommend downloading it again.
1
04/29/2018 8:54 am
Level 24 : Expert Engineer
TheCactus27
6/10 not enough M1 Garand
1
05/04/2018 7:10 pm
Level 1 : New Explorer
DubYT
Lol
1
03/31/2018 12:14 pm
Level 1 : New Miner
Gabrielthepro
Thanks god! I finally found a gun mod for my version! THANKS GOD!
1
04/02/2018 8:32 am
Level 43 : Master Modder
Luukn123
No problem man!
1
04/21/2018 12:38 pm
Level 1 : New Miner
Gabrielthepro
wait... I WAS WRONG! THIS IS FOR 1.12.2 VERSION! AND IM USING 1.12.1! MAKE A EDITION FOR THIS VERSION!
1
04/21/2018 9:20 pm
Level 15 : Journeyman Engineer
Nianor
Does it not work? Many 1.12.1 mods will work in 1.12.2, if I remember correctly.
1
04/14/2019 8:59 pm
Level 1 : New Miner
alexcraft12
he is using 1.12.1
not 1.12.2
1
03/31/2018 11:41 am
Level 43 : Master Modder
Luukn123
Updated to 1.3.1!
1
02/10/2018 6:44 pm
Level 1 : New Crafter
HotelDelta
This mod are so realistic
1
04/17/2019 12:49 pm
Level 1 : New Explorer
EnderYTV
This mod is so realistic* ^^
1
02/10/2018 6:44 pm
Level 1 : New Crafter
HotelDelta
Love u
1
02/07/2018 12:01 am
Level 41 : Master Skinner
Tengen_Horder
the models are cool
1
04/27/2018 11:11 am
Level 43 : Master Modder
Luukn123
Thanks! Glad you like it.
1
02/04/2018 12:01 pm
Level 2 : Apprentice Crafter
Titoo8899
cool mod, but I hope you make a 1.7.10 version of this
1
03/31/2018 12:15 pm
Level 1 : New Miner
Gabrielthepro
Lol we are not in 2012 WE ARE IN 2018 NOBODY USES ANYMORE 1.7.10
1
04/17/2019 12:50 pm
Level 1 : New Explorer
EnderYTV
some use it because they want to see how the modding comunity has changed or for the nastalgia
1
07/07/2018 2:34 pm
Level 1 : New Explorer
DubYT
1.7 was actually released in 2013
1
02/04/2018 12:10 pm
Level 15 : Journeyman Architect
MBlooby
We are almost in 1.13... No one is using 1.7.10 anymore lol
1
04/14/2019 9:00 pm
Level 1 : New Miner
alexcraft12
there is alot of peiople who use 1.7.10 not alot but they are in that version for the mods, but most people play on 1.12.2
1
02/25/2018 6:28 pm
Level 8 : Apprentice Cake
MmanGamer14
Beardielover, Hbminecraft and darkholmetenk, to name a few people not using 1.7.10

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome