Forumskeyboard_arrow_right Help keyboard_arrow_right Java Edition

Create Forum Thread
2

Cannot delete installations from the launcher (bug?)

2 emeralds3 replies374 views
created 07/20/2019 8:18 am by Jebaited history
last reply 07/21/2019 7:07 am
Hello!

I am having some trouble with the launcher and I was wondering if anybody is having the same issue and/or knows how to fix it.

I have a few installations on my launcher that have forge and optifine on them, but the issue is that for some reason I cannot install any mods with the seemingly glitched installations there and there is no option to delete them in the installations tab. they have the name "Unnamed Installation" and I cannot play them or remove them from the launcher. Additionally, while the glitched installations are there I cannot install forge or optifine on any new installations that I add because those also end up glitched too.

The other issue is that since the launcher glitched I cannot use any editing tools like MCEdit, because it is telling me that there is no Minecraft 1.12 jar file there even though I know there is (see attached image).



If anybody knows how to fix this please let me know.

Thank you


EDIT: I have now fixed the "Could not find Minecraft 1.12" error. The glitched installations are still there though.
Posted by avatar
Jebaited
Level 1 : New Miner
1

comment Login or register to post a reply.

3 replies

1
07/20/2019 8:39 am
Level 29 : Expert Sailor
-Eclipse-
you probably don't have 1.12.2 installed on your minecraft laucnher.
1
07/20/2019 8:46 am
Level 1 : New Miner
Jebaited
I have checked the versions folder and it is definitely there but it tells me that it's not. It's glitched, I think the best thing to do right now is check the Mojang bugs website.
1
07/21/2019 7:07 amhistory
Level 29 : Expert Sailor
-Eclipse-
ok try this.



step 1: Delete the 1.12.2 folder, and all the other 1.12.2 folders like forge, optifine for 1.12.2 (make sure that minecraft launcher is closed, i don't know if this has any effect but sometimes you need to close the launcher)

step 2: delete all of those 1.12.2 folders in your minecraft launcher like you did in the versions folder.
step 3: Go to your minecraft launcher and reinstall the version that you want (Probably 1.12.2)

step 4: then go to forge, and download forge 1.12.2 here: https://files.minecraftforge.net/

step 5: setup forge, you probably know how already (but if not. just double click the forge file and click on install client, this might take a moment) or for optifine which you can download here: https://optifine.net/downloads and double click that as well or put into the mods folder after you downloaded forge, and it should work.





make sure that you download the right version of forge and optifine, and all the mods that you are going to install, because the version is really important if you want to download and play with optifine for 1.12.2 but you have 1.12.1 installed it won't work.

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome