forum Forumskeyboard_arrow_right Help keyboard_arrow_right computerJava Edition

Create Forum Thread
2

No Gravity Command unuseable in Version 1.5.2

2 emeralds6 replies75 views
DenzelJordan started 02/27/2020 6:54 am
Bertiecrafter replied 02/28/2020 8:47 am
Im trying to get the Crossbow to fire arrows that go straight forward, ignoring gravity. I found this command that would work in Version 1.12.2 that i tried writing in a command block:

/entityarrow @e[​type=arrow] {NoGravity:1}

Is there an alternative command or a tweak that would get this to work in Version 1.15.2?
Posted by avatar
DenzelJordan
Level 1 : New Miner
0

comment Login or register to post a reply.

6 replies

2
02/28/2020 2:28 am
Level 25 : Expert Unicorn
HoboMaggot
/execute as @e[​type=arrow] run data merge entity @s {NoGravity:1b}
2
02/28/2020 8:47 amhistory
Level 47 : Master Robot
Bertiecrafter
Just to explain this a little more:

"/execute as" makes the command after "run" execute for every arrow. This is required, because for some stupid reason the data command only allows targetting one entity.
@s refers to the executing entity, which is the arrow in this case

The "b" in "{NoGravity:1b}" indicates the data type, an integer from -127 to 127. You can find the NBT structure here. And you can find instructions on how to write data types here.
An alternative is:
/execute as @e[​type=arrow] run data modify entity @s NoGravity set value 1b

I had exactly the same reaction when 1.13 changed tons of commands, I actually took a break for months if not years. Once I discovered the potential of the new command, I was totally on board.
1
02/28/2020 2:45 am
Level 45 : Master Birb
dreamCritting-
Wh- WHY IS IT THAT NOW?! The command worked fine in 1.12.2 and now they've changed it to this mess, this is why I don't use the new versions I cannot use the ruined commands.
1
02/28/2020 3:40 am
Level 25 : Expert Unicorn
HoboMaggot
/execute is actually so much more powerful now.
Its literally comparing the 1.12 commands to a beginners programming language, like Python to a much more advanced one like C++/Java.

With /execute we can make:
raycasting without tons of command blocks
directional teleportation without tons of command blocks
Homing Missiles using the new /execute store
Pewdiepie/water sheep boss Mainly the teleportation of entity models and entities

And these are the ones I remember
1
02/28/2020 12:45 am
Level 35 : Artisan Taco
spychicken123
entityarrow is not a command and to my knowledge never was. could possible be a mod. you might mean entitydata which has been somehow changed into part of the /execute command. i dont know how
2
02/28/2020 2:27 am
Level 25 : Expert Unicorn
HoboMaggot
Pretty sure op was talking about /entitydata
Planet Minecraft Logo

Website

© 2010 - 2020
www.planetminecraft.com

Welcome