Forumskeyboard_arrow_right Minecraft - Java Edition keyboard_arrow_right Data Packs

Create Forum Thread

What do YOU think should be good programming practices when making datapacks?

1 emeralds2 replies53 views
created 10/19/2019 10:18 pm by Amicdict history
last reply 10/20/2019 9:27 am
I mean as in setting scoreboard objectives and tag names, how you write function files, etc.
Posted by avatar
Level 46 : Master Engineer

comment Login or register to post a reply.

2 replies

10/20/2019 9:27 amhistory
Level 49 : Master Technomancer
In terms of naming scoreboards/tags it's a good practice to name them "<datapack name>.<scoreboard/tag name>" to avoid conflicts with other datapacks. A scoreboard objective's display name can be used as its description.
For example if you added an objective that detects carrot on a stick uses to a weapons datapack, it could be named more_weapons.carrot_clicks and have the display name "Number of right clicks with carrot on a stick".

In terms of function files I find it works better to have more smaller files than few larger ones. It makes the code more readable and usually more efficient.
10/20/2019 4:02 am
Level 41 : Master Robot
Have a look at what I said here at the bottom of my comment.

Planet Minecraft



© 2010 - 2019