1

Windows 8.1 Bukkit Server Help?!

1 emeralds20 replies4,597 views
HarrisonSJB started 01/09/2014 11:49 am
bmanrules replied 01/10/2014 2:25 pm
Hey guys. Recently I've been attempting to make a minecraft Bukkit server on Windows 8.1. I have a 64 bit operating system with Java 7. This is the code I am putting into my batch file:
@ECHO OFF
SET BINDIR=%~dp0
CD /D "%BINDIR%"
"%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
PAUSE

And this is my response:

C:\Users\Harrison\Desktop\Bukkit Server>java -Xmx1024M -jar craftbukkit.jar -o t
rue
'java' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Harrison\Desktop\Bukkit Server>PAUSE
Press any key to continue . . .


And yes, I have selected the entire output and pasted it into the thread, so it's 100% legit. No screenies required. Can anyone help? Does anyone know a solution? Pls reply asap. Just remember, windows 8.1, java 7 and 64 bit operating system.
Posted by avatar
HarrisonSJB
Level 47 : Master Turtle
19

comment Login or register to post a reply.

20 replies

1
01/10/2014 1:52 pm
Level 53 : Grandmaster Programmer
nickfromgreece
This is how you can fix this: WARNING DO THIS AT YOUR OWN RISK

1. open up a command prompt (DOS)
2. check that inside the jre folder theres a folder named bin
3. if there is type this in the command prompt:
setx PATH "%PATH%;C:\ProgramFiles(x86)\Java\jre7\bin"

Double check that the path above is correct, and the folder naming(might need spaces in program files)!!!

and DO NOT REMOVE THE QUOTES
1
01/10/2014 2:14 pm
Level 57 : Grandmaster Programmer
bmanrules
or:

Select Start -> Com­puter -> Sys­tem Prop­er­ties -> Advanced sys­tem set­tings -> Envi­ron­ment Vari­ables -> Sys­tem vari­ables -> PATH.
Prepend C:\Program Files\Java\jdk1.6.0_27\bin;to the begin­ning of the PATH variable.
your ver­sion of the jdk may be dif­fer­ent. If it is, change it to the name you have
don’t for­get that semi-colon(;) at the end (this is the sep­a­ra­tor char­ac­ter used between all the URLs in the path
Click OK three times.
1
01/10/2014 12:18 pm
Level 18 : Journeyman Wolf Whisperer
DeleteThisPleaseThan
HarrisonSJBHey guys. Recently I've been attempting to make a minecraft Bukkit server on Windows 8.1. I have a 64 bit operating system with Java 7. This is the code I am putting into my batch file:
@ECHO OFF
SET BINDIR=%~dp0
CD /D "%BINDIR%"
"%ProgramFiles%\Java\jre7\bin\java.exe" -Xmx1024M -Xms1024M -jar craftbukkit.jar
PAUSE

And this is my response:

C:\Users\Harrison\Desktop\Bukkit Server>java -Xmx1024M -jar craftbukkit.jar -o t
rue
'java' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Harrison\Desktop\Bukkit Server>PAUSE
Press any key to continue . . .


And yes, I have selected the entire output and pasted it into the thread, so it's 100% legit. No screenies required. Can anyone help? Does anyone know a solution? Pls reply asap. Just remember, windows 8.1, java 7 and 64 bit operating system.


you do not have Java set to your environment paths.
and you are not executing your batch file, rendering it pointless.
1
01/09/2014 1:57 pm
Level 51 : Grandmaster Programmer
DarkEyeDragon
Linux all the way xD
1
01/09/2014 2:15 pm
Level 53 : Grandmaster Programmer
nickfromgreece
^ I even use linux for my desktop now
1
01/09/2014 1:49 pm
Level 53 : Grandmaster Programmer
nickfromgreece
This means Java is not added in the PATH system variable I can tell you what to do but thats editing the core of the system 1 wrong move and its bye bye windows

oh and btw if you are thinking of setting up a permanent server on win 8.1 youre about to do a terrible mistake.
1
01/10/2014 11:54 am
Level 57 : Grandmaster Programmer
bmanrules
Editing Enviromental Values isn't editing the core of the system and can't really harm Windows. There is nothing wrong with setting up a server on Windows 8.1, as the OS itself is pretty easy on ram usage. Sure, Windows 8.1 server edition is probably better, but it won't matter too much on a Minecraft server. @The Linux comments the Linux Desktop OS you're using isn't much better than Windows 8.1. To run a server a version of Linux suited for servers would be smarter
1
01/10/2014 12:26 pm
Level 53 : Grandmaster Programmer
nickfromgreece
If you screw up the PATH variable the DOS wont be able to find all the executtables for the commands run.
1
01/09/2014 1:18 pm
Level 2 : Apprentice Miner
PlayerOne773
easiest workaround will be renaming your bukkit as minecraft_server. and just using
the file path provided for vanilla server on minecraft.net. it always works
1
01/09/2014 1:12 pm
Level 7 : Apprentice Farmer
Proud_Aussie
you might have Java 32bit
1
01/09/2014 12:27 pm
Level 1 : New Crafter
Unusuals
Had this problem and uninstalling java and reinstalling it works great I'm on windows 8.1 too if you want you can have my server.bat config but I use java -Xmx1024M -jar craftbukkit.jar -o true
PAUSE
1
01/09/2014 12:06 pm
Level 47 : Master Turtle
HarrisonSJB
Update: Just reinstalled java, but to no avail. I've reinstalled, used the same code, and I also used java -Xms1024M -Xmx1024M -jar craftbukkit.jar -o true but it still didn't work...
Any suggestions?
1
01/09/2014 11:54 am
Level 45 : Master Modder
Master1398
try putting just this into your WHATEVER.bat;
java -Xms1024M -Xmx1024M -jar craftbukkit.jar -o true
1
01/09/2014 11:56 am
Level 47 : Master Turtle
HarrisonSJB
Tried that mate :c Not workin'. I might just reinstall my java and come back with results.
1
01/09/2014 11:54 am
Level 12 : Journeyman Turtle
gorgonoff
HarrisonSJB
'java' is not recognized as an internal or external command,
operable program or batch file.


Try to re-install lava? And check java.com for more info about this problem.
1
01/09/2014 11:53 am
Level 57 : Grandmaster Programmer
bmanrules
Do you have JDK/Java added to your PATH?
1
01/09/2014 11:57 am
Level 47 : Master Turtle
HarrisonSJB
Dunno lol. Could you check for me and re-write the code so it would potentially work?
1
01/09/2014 1:35 pm
Level 57 : Grandmaster Programmer
bmanrules
None of the above comments will work You need to add Java to your enviromental PATH on your PC. I can't check for you because only you can, since I don't have access to your PC (Don't be lazy ). Code is fine though.
1
01/10/2014 1:47 pm
Level 47 : Master Turtle
HarrisonSJB
I have an actual folder called Java in path and it actually exists. I just don't understand why windows won't find it.
C: Drive (Local Disc) >>> Program Files (x86) >>> Java >>> jre7
Then it has a bin folder and a lib folder... Have I done sommet wrong?
1
01/10/2014 2:25 pm
Level 57 : Grandmaster Programmer
bmanrules
PATH and having a folder on your harddrive are two different things.
Planet Minecraft Logo

Website

© 2010 - 2020
www.planetminecraft.com

Welcome