Minecraft / Mods

[Any MC Version] Minecraft Java 7 Fix x32 and x64 bit

  • 5
  • 1
  • comment10
  • playlist_add
  • share
  • more_horiz
avatar Kristian3DS
Level 29 : Expert Miner
0
THIS FIX ONLY SUPPORTS WINDOWS

--CLIENT--
This fix makes minecraft run with java 7,
i didn't create the code but i modified the minecraft shortcut to make minecraft run with java 7
it will not modifie minecraft but it will modifie java 7, and i said modifie not destroy, and it will only be modified as long as the you are running this file,
go to the client folder inside the zip file to find the fix.

i don't know the exact reason why some computers can't run without this fix, but it has something to do with that minecraft runs ipv4 and java 7 runs ipv6 and that's all i know

--SERVER--
This fix can make your minecraft server run Java 7
go to the folder named server in the zip file
there will be two folders inside the folder, one named vanilla and one named bukkit
choose the server you use and follow these instructions

--VANILLA--

the vanilla server fix must be in the same folder as Minecraft_Server.exe
to start the server run the fix which will start the normal Minecraft_Server.exe

--BUKKIT--

the bukkit fix must be in the same folder as craftbukkit.jar
this fix will be the new batch to start the server
it will open the normal bukkit batch

i don't know the exact reason why some computers can't run without this fix, but it has something to do with that minecraft runs ipv4 and java 7 runs ipv6 and that's all i know

IMPORTANT!

--CLIENT--
the shortcut/fix MUST be in the same folder as minecraft.exe and remember to read the README!.txt

--SERVER--
the vanilla server fix MUST be in the same folder as Minecraft_Server.exe
and remember to read the README! SERVER.txt

the bukkit fix MUST be in the same folder as craftbukkit.jar
and remember to read the README! SERVER.txt

Error:

Read about the error: http://help.mojang.com/customer/portal/articles/542047-can-t-connect-to-minecraft-net

Enjoy and sorry for bad english :D
Progress100% complete
Game VersionMinecraft 1.6
Tags

4 Update Logs

Update #4 : 07/02/2013 4:45:09 amJul 2nd, 2013

Still works in 1.6
LOAD MORE LOGS

10 replies

1
07/02/2013 4:39 am
Level 29 : Expert Miner
Kristian3DS
Still works in 1.6
1
06/01/2013 8:34 am
Level 29 : Expert Miner
Kristian3DS
Still works in 1.6 snapshots
but you will need to rename MinecraftDev.exe to Minecraft.exe
1
11/22/2012 7:54 pm
Level 1 : New Miner
KingXKoK
does it work with minecraft 1.4.5?
1
11/24/2012 8:14 am
Level 29 : Expert Miner
Kristian3DS
Yes, it should work for any version as long you run Java 7
1
11/06/2012 7:49 pm
Level 34 : Artisan Soldier
UberDarkAardvark
my comp has no issue with java 7 :/ never heard of an issue, but ill diamond for potential.
1
11/02/2012 2:30 pm
Level 38 : Artisan Modder
LetheOfBavaria
There is no need of a java 7 fix....
1
11/13/2012 6:37 am
Level 1 : New Miner
sageonet
I am new at this game, but saw many posts in the forum from people having a lot of trouble with this,,,with all browsers. No one seemed to have found the solution....My question is,,,,where do I put the file? In the minecraft jar? I noticed that now there are 4 minecraft jars when I open the bin,,,so , when I place a mod,,,which one do I put it in? Does it make a difference? I think it might,,as the updated fly mod didn't work,,and crashed minecraft when I put it in the"minecraft jar" the one with 4 thousand some od bytes.....could someone help me here,,I want to try this one....I haven't been able to play on the site since I bought it, as there is always a java error,,,which matches those I have seen posted elsewhwere...I played off the desktop for a few months,,,but that went wacky after the last upgrade..I have uninstalled and reinstalled java and minecraft in every way imaginable,,,but it won't run,,even without the mod...
1
11/24/2012 8:24 am
Level 29 : Expert Miner
Kristian3DS
First you download the mod you want, then you need to open it with winrar or zip7, then you right click minecraft.jar and choose open with winrar, then drag the files from the mod in to minecraft.jar, then delete the folder META-INF inside minecraft.jar, then run minecraft



And this fix is a shortcut and you shall not place it in minecraft.jar

you shall place it in the same folder as minecraft.exe and run it
1
11/03/2012 11:45 am
Level 29 : Expert Miner
Kristian3DS
some computers will need this fix, my computer needs it.
the reason why some computers need it is because minecraft runs ipv4 and java 7 runs ipv6, but it works with java 7 for some computers.
1
11/09/2012 10:05 pm
Level 4 : Apprentice Crafter
notzoonable
ill buy that (not sarcastic)

Planet Minecraft

Browse

Site

© 2010 - 2019
planetminecraft.com

Welcome