So firstly I had a PNG that was too large. So I exported it with the same name as a jpg that would be smaller. And then I tried to upload the same jpg with a different name and then the same name but a png instead and that worked. I still don't understand what the issue was. I can understand the system having a size limit, but is your server using some kind of rewrite engine (common to apache and nginx) that couldn't cope with the filename? If so, why the error with down-view.jpg? It's very confusing.
AJAX reports 503 error on image upload
Browser: Brave
OS: Linux
Steps to reproduce: add an image to content within the size limit on my most recent map, Mandala Box. First two images loaded without issue. Third image appears to upload but then deletes and a dialogue appears with the following message:
One or more errors occurred while uploading your images:
* Error on 2026-02-12_02.03.46.jpg: Error: AJAX reported 503
I thought it might be an issue with the filename so I tried to upload with the name down-view.jpg and got the same error. And then I tried changing it to a PNG file and it worked. So the point of this bug report is to request that in the content screen it is very clearly noted what types of files and the upload size limit is acceptable so users like myself don't have to experiment like this.